Bug #62127

FAL image in translation of Record not working

Added by Rüdiger Marwein about 6 years ago. Updated over 5 years ago.

Status:
Rejected
Priority:
Must have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
-
Start date:
2014-10-09
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
5.4
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

We experience problems with FAL and translated records used in extbase/fluid.

Usecase 1:
  1. An extbase extension brings it's own records. These records contain a FAL image.
  2. A plugin uses Extbase and Fluid to display the record data.
  3. Such a record is created, an image assigned.
  4. This record gets translated.

Should:
In the frontend the Image should appear in the default language and the image should appear in the translation.

Current state:
The image does not show up in the translated frontend even though it's visible in the backend.

Usecase 2:
  1. An extbase extension brings it's own records. These records contain a FAL image.
  2. A plugin uses Extbase and Fluid to display the record data.
  3. Such a record is created, an image assigned.
  4. This record gets translated.
  5. The image in the translation gets replaced by another picture.

Should:
In the frontend the Image of the translation should appear in the translation, the original image should show up at the default language.

Current state:
The image does not show up in the translated frontend (mode strict) or falls back to the one of the default language even though it's visible in the backend.

You can use the attached example extension to reproduce the behaviour.
A root level template and languages 0 and 1 are assumed.


Files

test_inline_translation.zip (535 KB) test_inline_translation.zip Rüdiger Marwein, 2014-10-09 15:09

Related issues

Related to TYPO3 Core - Bug #57272: Extbase doesn't handle FAL translations correctlyClosed2014-03-25

Actions
Related to TYPO3 Core - Bug #62155: IRRE at localized records not working properly with Extbase/Fluid Rejected2014-10-10

Actions
#1

Updated by Andreas Wolf over 5 years ago

  • Status changed from New to Rejected

This is actually a duplicate of #57272.

@Rüdiger: can you check if the patch attached there fixes your problem? If not, we have to further investigate this issue. I’ll reopen then.

Also available in: Atom PDF