Bug #62155

IRRE at localized records not working properly with Extbase/Fluid

Added by Rüdiger Marwein almost 5 years ago. Updated over 4 years ago.

Status:
Rejected
Priority:
Must have
Assignee:
-
Category:
FormEngine aka TCEforms
Target version:
-
Start date:
2014-10-10
Due date:
% Done:

0%

TYPO3 Version:
6.2
PHP Version:
5.4
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

We experience problems with IRRE and translated records used in extbase/fluid.

  1. An extbase extension brings it's own records. These records contain an IRRE field.
  2. A plugin uses Extbase and Fluid to display the record data.
  3. Such a record is created, two IRRE records attached inline.
  4. This record gets translated.
Usecase 1 (works):
  1. no further action

Result:
Two IRRE records show up in the translated frontend.

Usecase 2 (works):
  1. The IRRE records are localized via the "Localize all records" button.

Result:
Two translated IRRE records show up in the translated frontend.

Usecase 3 (does not work):
  1. The IRRE records are localized via the "Localize all records" button.
  2. A new IRRE record is attached to the localized record.

Should:
Three IRRE records should show up in the translated frontend. (no localization parent is set)

Current state:
Two IRRE record show up in the translated frontend. The newly created one is missing, even though visible in the backend.

Usecase 4 (does not work):
  1. The records are localized via the "Localize all records" button.
  2. One IRRE record is removed from the localized record.

Should:
One IRRE record should show up in the translated frontend.

Current state:
In strict mode it's fine, only one IRRE record shows up in the translated frontend.
In fallback mode, one localized record shows up even and one IRRE record of the default language even though only one record is visible in the backend.

Usecase 5 (does not work):
  1. The records are localized via the "Localize all records" button.
  2. The records are removed and two new ones are attached.

Should:
Two IRRE record should show up in the translated frontend.

Current state:
In strict mode zero IRRE records show up in the translated frontend.
In fallback mode, two IRRE records of the default language show up even though not visible in the backend.

You can use the attached example extension to reproduce the behaviour. I included a t3d with the described setup as well.
Languages 0 and 1 are assumed.

test_inline_translation.zip - Demo Extension including t3d export showing the usecases (636 KB) Rüdiger Marwein, 2014-10-10 20:06


Related issues

Related to TYPO3 Core - Bug #59192: mergeIfNotBlank with FAL records Closed 2014-05-28
Related to TYPO3 Core - Bug #61045: RECORDS and languageField not working Closed 2014-08-18
Related to TYPO3 Core - Bug #62127: FAL image in translation of Record not working Rejected 2014-10-09
Related to TYPO3 Core - Bug #61689: Error on localizing FAL record in workspace New 2014-09-17
Related to TYPO3 Core - Bug #61719: Warnings on flushing whole workspace with localizations New 2014-09-18
Related to TYPO3 Core - Bug #61674: Extbase doesn't handle collection translations properly Closed 2014-09-17
Related to TYPO3 Core - Bug #61543: Language Fallback fails when displaying records, which have translation for other languages but not the current language Closed 2014-09-11
Related to TYPO3 Core - Bug #46217: Notification emails not translated for default recipients Closed 2013-03-12

History

#1 Updated by Andreas Wolf over 4 years ago

  • Status changed from New to Rejected

Duplicate of #57272, though I think the description in here goes further than this issue. The general inconsistency between FormEngine and Extbase behaviour is the same though.

@Rüdiger: could you check if the patch in the review for #57272 fixes your problem?

Also available in: Atom PDF