Bug #63081

Setting [SYS][ddmmyy] does not change format of date in extbase extensions flexform

Added by Christof Hagedorn about 7 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2014-11-19
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

f.e. setting
[SYS][ddmmyy] f.e. to "d.m.Y"
in the install tool
does not change the format of date in the flexform of an extension with starttime, endtime fields.

The format of the date textfield left to the calendar is allways H:i d-m-y

#1

Updated by Riccardo De Contardi about 6 years ago

It seems still present on 7.6.1-dev (latest master). What should that settings do?

#2

Updated by Riccardo De Contardi about 6 years ago

  • Category set to Backend User Interface

It seems still present on 7.6.1-dev (latest master). What should that settings do?

#3

Updated by Susanne Moog almost 2 years ago

  • Status changed from New to Closed

This is by design. TCA (and by inheritance FlexForms) dates are documented with:

The field will evaluate the input as a date, automatically converting the input to a UNIX-time in seconds. The value stored in the database will be in UTC! That means that any input in the Backend will be treated as a local time (default timezone is either set by PHP configuration or in the Install Tool), but will be stored in UTC. The display will be like “12-8-2003” (assuming UTC+2) while the database value stored will be “1060639200”.

see https://docs.typo3.org/m/typo3/reference-tca/master/en-us/ColumnsConfig/Type/Input.html#id25

The setting basically only changes how TYPO3 displays "static" dates.

The only setting relevant to displaying dates in form is "USdateFormat" which switches between HH:mm MM-DD-YYYY and HH:mm DD-MM-YYYY.

Also available in: Atom PDF