Bug #63917

If no func wizard ext is installed, exception is thrown (due to PHP warning)

Added by Georg Ringer almost 7 years ago. Updated almost 7 years ago.

Status:
Rejected
Priority:
Must have
Assignee:
-
Category:
Backend API
Target version:
Start date:
2014-12-16
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

if the ext "func" is installed, but no wizard itself, an exception is shown:

#1: PHP Warning: Creating default object from empty value in typo3/sysext/backend/Classes/Module/BaseScriptClass.php line 341


Related issues

Related to TYPO3 Core - Bug #21975: Web->Function: empty frame if all related ext removedClosed2010-01-17

Actions
#1

Updated by Gerrit Code Review almost 7 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/35515

#2

Updated by Gerrit Code Review almost 7 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/35515

#3

Updated by Markus Klein almost 7 years ago

  • Subject changed from If no func wizard ext is installed, exception is thrown to If no func wizard ext is installed, exception is thrown (due to PHP warning)
#4

Updated by Mathias Schreiber almost 7 years ago

  • Target version changed from 7.0 to 7.1 (Cleanup)
#5

Updated by Mathias Schreiber almost 7 years ago

  • Status changed from Under Review to Rejected

fixed with a more meaningful error message in #21975

Also available in: Atom PDF