Project

General

Profile

Actions

Bug #64140

closed

BE and FE user passwords are not encrypted when saving record form in backend

Added by Nils Heuermann over 9 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Authentication
Target version:
Start date:
2015-01-06
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
7
PHP Version:
5.5
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

When saving a backend or frontend user (using the general backend record form) the passwords are not encrypted by saltedpasswords anymore.

The reason are old class names in the formevals configuration in ext_localconf.php as well as in TCA/Overrides:
  • tx_saltedpasswords_eval_fe must be TYPO3\CMS\Saltedpasswords\Evaluation\FrontendEvaluator
  • tx_saltedpasswords_eval_be must be TYPO3\CMS\Saltedpasswords\Evaluation\BackendEvaluator

Enabling EXT:compatibility6 brings the old class names back and the encryption is done correctly.
So it's not a general issue just wrong configuration values.

Actions

Also available in: Atom PDF