Bug #64215

Suggest wizard should respect options.pageTree.altElementBrowserMountPoints

Added by Alexander Stehlik over 5 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
FormEngine aka TCEforms
Target version:
-
Start date:
2015-01-09
Due date:
% Done:

100%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
medium
Is Regression:
No
Sprint Focus:

Description

With the TypoScript option

options.pageTree.altElementBrowserMountPoints

you can configure alternative mount points that are used in the element browser.

This is currently not consistently handled by the suggest wizard. The wizard will have access to different pages than the element browser.

IMO this should be unified.

Associated revisions

Revision 40a79c0a (diff)
Added by Alexander Stehlik over 1 year ago

[TASK] Respect alternative web mounts in suggest wizard

The suggest wizard now respects temporary page tree mount
points and altElementBrowserMountPoints from the TSconfig.

The detection and adjustment of element browser mountpoints
is centralized in the backend user.

Resolves: #64215
Releases: master
Change-Id: Ic8eaf0cd2155051db0f3bed0678087ec72b9fadb
Reviewed-on: https://review.typo3.org/57193
Tested-by: TYPO3com <>
Reviewed-by: Benni Mack <>
Tested-by: Benni Mack <>
Reviewed-by: Georg Ringer <>
Tested-by: Georg Ringer <>
Reviewed-by: Anja Leichsenring <>
Tested-by: Anja Leichsenring <>

History

#1 Updated by Alexander Opitz over 2 years ago

  • Status changed from New to Needs Feedback

IMHO this parts were unified in newer versions, so this should be handled now consistent. Or do I miss something?

#2 Updated by Riccardo De Contardi about 2 years ago

  • Status changed from Needs Feedback to Closed

No feedback since the last 90 days => closing this issue.

If you think that this is the wrong decision or experience the issue again and have more information about how to reproduce your problem, please reopen it or open a new issue with a reference to this one.

Thank you and best regards

#3 Updated by Alexander Stehlik almost 2 years ago

I just did some tests with the current master.

The issue still seems to be valid. When a suggest Wizard is used together with an element browser it ignores this setting:

options.pageTree.altElementBrowserMountPoints

The suggest wizard only finds pages within the normal database mounts of the user.

Please reopen the issue.

#4 Updated by Alexander Stehlik almost 2 years ago

A possible alternative solution would be to use the suggest Wizard TSconfig (example for User TSconfig):

options.pageTree.altElementBrowserMountPoints = 1

page.TCEFORM.pages.content_from_pid.suggest.default {
    pidList = 1
    pidDepth = 99
}

But there is still one problem:

The suggest wizard limits the results by checking the permissions in checkRecordAccess(). Is uses BackendUtility::readPageAccess($uid, $GLOBALS['BE_USER']->getPagePermsClause(Permission::PAGE_SHOW) when used for pages.

Therefore code needs to be added that sets alternate webmounts when the pidList setting is used like in the DatabaseBrowser.

#5 Updated by Gerrit Code Review almost 2 years ago

  • Status changed from Closed to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57193

#6 Updated by Gerrit Code Review almost 2 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57193

#7 Updated by Gerrit Code Review over 1 year ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57193

#8 Updated by Alexander Stehlik over 1 year ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#9 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF