Bug #64942

Racecondition in Extractor Registry for Indexing FAL files

Added by Stefan L almost 6 years ago. Updated about 1 month ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
-
Start date:
2015-02-09
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Hi,

there seems to be a bug where two or more Extractors of a FAL driver can not share the same priority.
They overwrite each other

typo3/sysext/core/Classes/Resource/Index/ExtractorRegistry.php
Function getExtractorsWithDriverSupport
Line 99 (and duplicated) 101

i would expect two extractors with the same priority to work in random order

The same occurs in typo3/sysext/core/Classes/Resource/Index/Indexer.php:105

bye


Related issues

Related to TYPO3 Core - Bug #56727: ExtractorRegistry can not handle Extractors with same ExecutionPriorityClosed2014-03-10

Actions
Related to TYPO3 Core - Bug #92643: Fix FAL meta data extraction prioritiesUnder Review2020-10-21

Actions
#1

Updated by Riccardo De Contardi about 4 years ago

  • Category set to File Abstraction Layer (FAL)
#2

Updated by Gerrit Code Review over 1 year ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/59894

#3

Updated by Gerrit Code Review over 1 year ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/59894

#4

Updated by Gerrit Code Review over 1 year ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/59894

#5

Updated by Gerrit Code Review over 1 year ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/59894

#6

Updated by Gerrit Code Review over 1 year ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/59894

#7

Updated by Gerrit Code Review over 1 year ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/59894

#8

Updated by Gerrit Code Review over 1 year ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/59894

#9

Updated by Anonymous over 1 year ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#10

Updated by Benni Mack 11 months ago

  • Status changed from Resolved to Closed
#11

Updated by Helmut Hummel about 1 month ago

  • Status changed from Closed to Accepted
  • TYPO3 Version changed from 6.2 to 9

This issue isn't resolved yet. Extractors can have same priority, but the extracted meta data of extractors with same priority will still be overwritten.

#12

Updated by Helmut Hummel about 1 month ago

  • Related to Bug #56727: ExtractorRegistry can not handle Extractors with same ExecutionPriority added
#13

Updated by Helmut Hummel about 1 month ago

  • Status changed from Accepted to Closed

Since there are more things to fix, I will create a new ticket

#14

Updated by Helmut Hummel about 1 month ago

  • Related to Bug #92643: Fix FAL meta data extraction priorities added

Also available in: Atom PDF