Bug #64971

Static access to enumeration constants requires instance once

Added by Mathias Brodala over 6 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Must have
Category:
Miscellaneous
Target version:
Start date:
2015-02-10
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
easy
Is Regression:
No
Sprint Focus:
Stabilization Sprint

Description

With #61090 retrieving constants from an Enumeration was simplified by static access.

This however does not work if no Enuemration instance was created before retrieving the constants. The reasons is that the actual constant values are only loaded upon creation of an instance (instance method loadValues()).

This needs to be fixed my making loadValues() static, too.


Related issues

Related to TYPO3 Core - Bug #61090: Static access to Enumeration constantsClosed2014-08-20

Actions
#1

Updated by Gerrit Code Review over 6 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/36794

#2

Updated by Christian Kuhn over 6 years ago

  • Sprint Focus set to Stabilization Sprint
#3

Updated by Gerrit Code Review over 6 years ago

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/37027

#4

Updated by Mathias Brodala over 6 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 50 to 100
#5

Updated by Benni Mack over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF