Project

General

Profile

Actions

Bug #65026

closed

INSERT of ext_tables_static+adt.sql not mapped

Added by Andreas Kienast about 9 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Should have
Category:
Install Tool
Target version:
Start date:
2015-02-12
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Due to the wrong used database object the table names in an INSERT statement run in Install Tool are not mapped properly.

Actions #1

Updated by Gerrit Code Review about 9 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/36859

Actions #2

Updated by Gerrit Code Review about 9 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/36859

Actions #3

Updated by Gerrit Code Review about 9 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/36859

Actions #4

Updated by Gerrit Code Review about 9 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/36859

Actions #5

Updated by Mathias Schreiber over 8 years ago

  • Target version deleted (next-patchlevel)
Actions #6

Updated by Andreas Kienast about 8 years ago

  • Status changed from Under Review to New
  • Target version set to 8 LTS

will be tackled with v8

Actions #7

Updated by Nicole Cordes about 7 years ago

Which steps have to be done to reproduce the problem described?

Actions #8

Updated by Andreas Kienast about 7 years ago

Puh, that's pretty old ;) IIRC the original table name and field names were used instead of the ones defined in the DBAL mapping. Means, you need to map a table to another name and in the Install Tool, the original name is still used.

Actions #9

Updated by Nicole Cordes about 7 years ago

For better understanding the problem, see https://docs.typo3.org/typo3cms/extensions/dbal/Configuration/Mapping/Index.html with mapping examples. The problem seems to be that the file content of ext_tables_static+adt.sql files is either not parsed (and mapped) or something is broken inside the parser.

Actions #10

Updated by Benni Mack almost 7 years ago

  • Target version changed from 8 LTS to next-patchlevel
Actions #11

Updated by Christian Kuhn over 5 years ago

  • Status changed from New to Closed

Hey. I'll take the freedom to close this: i'd guess that issue vanished in v8 - no dbal there, anymore. If still an issue and still needs a fix, it would probably go to the outsourced dbal ext anyway.

Actions

Also available in: Atom PDF