Bug #65446

Translation of IRRE not working

Added by Jeff C over 4 years ago. Updated about 1 year ago.

Status:
Accepted
Priority:
Should have
Assignee:
-
Category:
FormEngine aka TCEforms
Target version:
-
Start date:
2015-03-02
Due date:
% Done:

0%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

According to this past bug report (https://forge.typo3.org/issues/56882) the translation of inline records should be working, but I assume that this only means FAL-records. Custom inline records are still not translatable.

What happens:

  • I place my Plug-In in default language and add inline-records.
  • I translate the Plug-In to an other language.
  • The translated Plug-In holds the same records as the original. The Plug-In is now set to the new language, but the records are still in default language.
  • Additional to that for every original record in default language there is another, hidden record.
  • When trying to expand, unhide, delete or edit the hidden records, an javaScript-error is logged. The same happens upon clicking on the "Synchronize with original language"- and "Localize all"-buttons. The error message reads:

SyntaxError: unterminated string literal

inline.deleteRecord('data-1-tt_content-940-pi_flexform---data---main---lDEF---s

This not only happens in my own extensions but also in existing ones like powermail. I happens in 7.0-installations but also in 6.2 as far as I tested it.

Schermata 2018-04-08 alle 17.55.48.png View (56.8 KB) Riccardo De Contardi, 2018-04-08 17:56

History

#1 Updated by Riccardo De Contardi over 3 years ago

  • Status changed from New to Needs Feedback

Hi Jeff, can you test again on version 6.2.15?
I just tried with the latest version of Powermail and I got no problems in translating everything.

this is my procedure:

1) create a new page (L=0, italian; L=1, english) "Prova"
1.1) translate it into "Prova English"
2) create a sysfolder "Powermail"
2.1) translate it into "Powermail English"
3) on the sysfolder: create a powermail form:
3.1) create the form "Nuovo form"
3.2) create new "pages": "Principale"
3.3) create new field: "Nome", "Cognome" (input fields) and "Invia" (submit button).
4) on "Prova" > create a new content element > plugin > powermail > set "nuovo form" as powermail form.

now the eglish part:
5) on "Powermail" > list view > "Nuovo form" > click on "localize to: english"
6) I named the english form "new form in english" and clicked on "localize all records" and it created all pages and fields in english from the italian ones, so I named them, "general" and so forth: "Name", "Surname", "Submit".

7) page "Prova" > "languages" view > copy default content elements > it creates a new plugin content element, which automatically sets its form to "new form in english"

On frontend, the two pages have their correct form.

Do you think it is sufficient? Or should I perform a different test? Can you provide us your extension and a procedure about how to reproduce the issue? Thank you!

#2 Updated by Riccardo De Contardi over 3 years ago

  • Status changed from Needs Feedback to Closed

No feedback within the last 90 days => closing this issue.

If you think that this is the wrong decision or experience this issue again, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.
You could also join the #typo3-cms channel in Slack if you still need support.
Thank you

#3 Updated by Claus Due over 2 years ago

  • Status changed from Closed to Accepted

Revived, a solution has been found. Patch will come shortly.

#4 Updated by Claus Due about 2 years ago

Sorry for not coming back to this one. It turns out this wasn't the problem my client faced, it merely had the same symptoms minus the logged JS error. I was able to create a workaround - I'm still not completely sure it is the same problem as the one reported here, but my client's problems were that if you edit a non-ilve workspace and FormEngine is allowed to show an IRRE field which contains relations that have been versioned, this would cause an error on 7.6 and an ignored operation on 8.x+ and duplicates would be shown in the IRRE list. All of which could very easily affect the JS that gets generated - and this could also explain why 8.x+ behaves differently. Requirements obviously are that the IRRE field or the flexform field which contains the IRRE field must be translatable (and for my use case, the child records must support versioning too).

I wish I had more information about the use case I had, but I'm unable to revive the project. If you're unable to reproduce this easily I guess it would be perfectly fine to close this issue again.

#5 Updated by Riccardo De Contardi about 1 year ago

I repeated the same test I performed on my comment 1 on TYPO3 8.7.12 with the latest Powermail plugin.

The results are the same - there is only just a difference:

When I translate the form plugin (Point 7) from the languages view:
- the "preview" of the CE correctly shows that the form is "New form in English" (see attached screenshot)
- when editing the CE in english, the Tab main settings > Choose a Powermail Form shows "Nuovo Form" instead. On frontend, the correct translated form is shown. I don't know if it is a powermail issue.
- This happens with both "Translated" and "Copy" mode.

Do you think it is sufficient to consider this issue closed? Thank you!

Also available in: Atom PDF