Bug #65506

Links inside list elements not working propery

Added by Dominik Hahn almost 3 years ago. Updated 4 months ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Content Rendering
Target version:
Start date:
2015-03-04
Due date:
% Done:

100%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:
Stabilization Sprint

Description

We are facing a problem with links inside list elements in the front end.

When linking a text by using the link wizard the RTE shows the link just fine. On the front end the link is totally fine unless it's surrounded by "<li></li>".

This is a link in a paragraph:
<a href="/formular/" title="Verweis auf weitere Informationen" class="internal-link">Ein ganz normaler Link</a>

The same link inside an unordered list:
<li><link 10776="" -="" internal-link="" "verweis="" auf="" weitere="" informationen"="">Ein ganz normaler Link</li>

I think it might be because of the "-" in the class of the link but as we had to got back to TYPO3 6.2.9 I can't test this anymore.

This problem was present in TYPO3 6.2.10RC1 and is still present in TYPO3 6.2.10


Related issues

Related to TYPO3 Core - Bug #61954: Click-enlarge problem when an image is inside ul li OR ol li New 2014-09-29

Associated revisions

Revision 9bab6234 (diff)
Added by Nicole Cordes almost 3 years ago

[BUGFIX] Re-add parsing for list elements

Due to patch https://review.typo3.org/33613/ the parsing of list
elements get broken. This patch re-adds parsing for those.

Releases: master, 6.2
Resolves: #65506
Change-Id: I4a5a17cf4e3b033724111955f165d9e71ca826aa
Reviewed-on: http://review.typo3.org/37541
Reviewed-by: Jigal van Hemert <>
Tested-by: Jigal van Hemert <>
Reviewed-by: Nicole Cordes <>
Tested-by: Nicole Cordes <>

Revision 07be3dfc (diff)
Added by Nicole Cordes almost 3 years ago

[BUGFIX] Re-add parsing for list elements

Due to patch https://review.typo3.org/33613/ the parsing of list
elements get broken. The issue only occurs if you have added the li tag
as external block element manually without any block configuration.
As this used to work in 6.2 this patch re-adds parsing for those tags.

Releases: master, 6.2
Resolves: #65506
Change-Id: I12c93b2f6aa2bdd073c5af8d7e6eff2433ec9030
Reviewed-on: http://review.typo3.org/38656
Reviewed-by: Jigal van Hemert <>
Tested-by: Jigal van Hemert <>
Reviewed-by: Andreas Fernandez <>
Tested-by: Andreas Fernandez <>

Revision f2c6a5c6 (diff)
Added by Andreas Fernandez almost 3 years ago

[BUGFIX] Re-add parsing for list elements

Due to patch https://review.typo3.org/33613/ the parsing of list
elements get broken. The issue only occurs if you have added the li tag
as external block element manually without any block configuration.
As this used to work in 6.2 this patch re-adds parsing for those tags.

Releases: master, 6.2
Resolves: #65506
Change-Id: I12c93b2f6aa2bdd073c5af8d7e6eff2433ec9030
Reviewed-on: http://review.typo3.org/38681
Reviewed-by: Andreas Fernandez <>
Tested-by: Andreas Fernandez <>

Revision 0e5ec28b (diff)
Added by Sebastian Hofer 4 months ago

[BUGFIX] Fix link rendering in li tag

Changes the rendering for li tags in RTE in sys ext css_styled_content.
This change is based on a former bugifx for TYPO3 6.2:
https://review.typo3.org/#/c/38681/

The fix was not ported to css_styled_content for TYPO3 7,
so the issue is present in TYPO3 7 if no fluid_styled_content
TypoScript is present.

Releases: 7.6
Resolves: #65506
Change-Id: I1aa744b7f381681a01cb797ff6dd9c61f221934a
Reviewed-on: https://review.typo3.org/54165
Tested-by: TYPO3com <>
Reviewed-by: Wouter Wolters <>
Tested-by: Wouter Wolters <>
Reviewed-by: Benjamin Kott <>
Tested-by: Benjamin Kott <>

History

#1 Updated by Paul Keller almost 3 years ago

I can confirm the same problem after the update from 6.2.9 to 6.2.10.
List elements with links within RTE don't work in frontend anymore after update. If I use core of 6.2.9 again, everything is fine. A soon as I switch back to 6.2.10 problem occurs again.

#2 Updated by Nicole Cordes almost 3 years ago

  • Assignee set to Nicole Cordes
  • Target version set to next-patchlevel
  • Is Regression changed from No to Yes

#3 Updated by Gerrit Code Review almost 3 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/37541

#4 Updated by Gerrit Code Review almost 3 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/37541

#5 Updated by Xavier Perseguers almost 3 years ago

  • Target version changed from next-patchlevel to 6.2.12
  • Sprint Focus set to Stabilization Sprint

#6 Updated by Gerrit Code Review almost 3 years ago

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/38656

#7 Updated by Gerrit Code Review almost 3 years ago

Patch set 2 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/38656

#8 Updated by Nicole Cordes almost 3 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#9 Updated by Xavier Perseguers almost 3 years ago

  • Status changed from Resolved to Under Review
  • % Done changed from 100 to 50

#10 Updated by Gerrit Code Review almost 3 years ago

Patch set 3 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/38656

#11 Updated by Gerrit Code Review almost 3 years ago

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/38681

#12 Updated by Nicole Cordes almost 3 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 50 to 100

#13 Updated by Daniel Schwarz over 1 year ago

This problem is present again in TYPO3 7.6.9. I do not know if it is also present in earlier v7.x versions.

#14 Updated by Nicole Cordes over 1 year ago

I cannot reproduce the issue neither with 7.6 nor with the current master. Could you give some steps to reproduce? Have you changed the TypoScript from css_styled_content or fluid_styled_content?

#15 Updated by Ralph Brugger over 1 year ago

Same issue here, same issue as in TYPO3 6.2.x

Try this:

typo3_src-7.6.9/typo3/sysext/css_styled_content/static/setup.txt

               # List processing
                dl < .div
                dd < .div
                ol < .div
                ul < .div
+++             li.stdWrap.parseFunc < lib.parseFunc

It worked for us / same code as for 6.2.x

#16 Updated by Florian Rival over 1 year ago

Same issue for me in Typo3 7.6.9 with fluid_styled_content.
I tried the Ralph Brugger's workaround without success.

Backend :

<em>the <a href="http://www.website.com/?id=13">bug is here</a></em>

Front end result :

<em>the <link 13="">bug is here</em>

The <i> tags are changed in <em> tag with this TS - but even without this TS the problem is there :

lib.parseFunc_RTE.tags{
    b = TEXT
    b{
        current=1
        wrap= <strong>|</strong>
    }
    i = TEXT
    i{
        current=1
        wrap= <em>|</em>
    }
}

lib.parseFunc.tags{
    b = TEXT
    b{
        current=1
        wrap= <strong>|</strong>
    }
    i = TEXT
    i{
        current=1
        wrap= <em>|</em>
    }
}

#17 Updated by Riccardo De Contardi 4 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF