Story #65729

Add GD2 alternative for ImageMagick/GraphicsMagick to the core

Added by Job Rutgers over 4 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2015-03-14
Due date:
% Done:

0%

TYPO3 Version:
7
PHP Version:
Tags:
Sprint Focus:

Description

Most hosting providers disable exec() so ImageMagick/GraphicsMagick won't work. In my opinion Typo3 should automatically fall back to a GD2 like solution for processing images if ImageMagick/GraphicsMagick doesn't work. So something like jb_gd_resize of srgd should be included to the core to make Typo3 usable out of the box for users without ImageMagick/GraphicsMagick.


Related issues

Related to TYPO3 Core - Feature #20107: Image Resizing / Thumbnails with GD2 instead of ImageMagick Rejected 2009-02-28

History

#1 Updated by Xavier Perseguers over 4 years ago

As you pointed out there is a solution with jb_gd_resize so you should just use it. TYPO3 is considered to be an Enterprise CMS and as such has some requirements that are easily met with many hosting providers. If you have one that does not meet those requirements, you should either switch (it's so easy and not costly nowadays) or rely on such 3rd-party extension, if it works for you.

#2 Updated by Riccardo De Contardi about 4 years ago

  • Status changed from New to Closed

I close this as a duplicate of #20107 please continue the discussion there
Thank you.

I added a relation between this and #20107 to keep track of it.

Also available in: Atom PDF