Bug #66357

Install Tool is stuck into databaseData step

Added by Xavier Perseguers over 7 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Install Tool
Target version:
-
Start date:
2015-04-10
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
5.6
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

How to reproduce

  1. Grab a remote database dump containing a view different from local DB user (e.g., whose definer is "root@%" whereas locally you'll have "typo3_localsite").
  2. Restore the dump into your local database
  3. Go to install tool (/typo3/install)

You are now stuck on step "Create user and import base data" because \TYPO3\CMS\Core\Database\DatabaseConnection::admin_get_tables() is unable to fetch tables due to this VIEW which you are not allowed to access (and which has nothing to do with any TYPO3 requirements).

Possible solution

Make \TYPO3\CMS\Install\Controller\Action\Step\DatabaseData::needsExecution() have a more targeted condition.


Related issues

Related to TYPO3 Core - Bug #61571: Database analyzer considers MySQL Views as tablesClosed2014-09-14

Actions
Related to TYPO3 Core - Bug #70247: InstallTool - Handling of Views incorrectClosed2015-10-01

Actions
#1

Updated by Sinisa Mitrovic about 7 years ago

Hello,

When I try to install TYPO3 7.3.1 I'm stuck at this step also. Any suggestion?

Best regards,
Sinisa Mitrovic

#2

Updated by Mathias Schreiber over 6 years ago

  • Target version deleted (next-patchlevel)
#3

Updated by Christian Kuhn over 4 years ago

  • Status changed from New to Closed

i think this has been fixed with the doctrine switch.

Also available in: Atom PDF