Bug #66429

Remove IdentityMap

Added by Mathias Brodala over 4 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Must have
Category:
Extbase
Target version:
Start date:
2015-04-15
Due date:
% Done:

100%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

The IdentityMap class has been deprecated since 6.1 and should be removed now.

Within Repository it is completely unused already by the core.

In the DataMapper it is still used but can be simply replaced with calls to the persistence session instead.

One huge advantage is being able to trigger garbage collection for mapped objects after unregistering them from the persistence session which can free a lot of memory.


Related issues

Related to TYPO3 Core - Bug #67630: Loop when resolving circular relations Closed 2015-06-19

Associated revisions

Revision b6dad8fc (diff)
Added by Mathias Brodala over 4 years ago

[!!!][TASK] Remove IdentityMap from persistence

The IdentityMap class has been deprecated since 6.1 and is removed
from the Extbase persistence.

Resolves: #66429
Releases: master
Change-Id: I150b86190bbe7d0c9431d5495c8460241681f439
Reviewed-on: http://review.typo3.org/38701
Reviewed-by: Nicole Cordes <>
Tested-by: Nicole Cordes <>
Reviewed-by: Andreas Fernandez <>
Tested-by: Andreas Fernandez <>

Revision 91d12569 (diff)
Added by Felix Oertel about 4 years ago

[BUGFIX] Infinite loop with circular relations

When resolving circular relations, extbase fails with an
infinite loop because the DataMapper waits for all sub-
objects to be mapped before registering them to the session.
The sub-objects can thus not find the parent object in the
session and the loop begins.

Resolves: #67630
Related: #66429
Releases: master
Change-Id: Ie20e2690323a00d8f54f3af5ce2fce87715f4247
Reviewed-on: http://review.typo3.org/40471
Reviewed-by: Helmut Hummel <>
Tested-by: Helmut Hummel <>
Reviewed-by: Wouter Wolters <>
Reviewed-by: Nicole Cordes <>
Tested-by: Nicole Cordes <>

Revision 8fa7a66d (diff)
Added by Felix Oertel about 4 years ago

[BUGFIX] Infinite loop with circular relations

When resolving circular relations, extbase fails with an
infinite loop because the DataMapper waits for all sub-
objects to be mapped before registering them to the session.
The sub-objects can thus not find the parent object in the
session and the loop begins.

Resolves: #67630
Related: #66429
Releases: master
Change-Id: Ie20e2690323a00d8f54f3af5ce2fce87715f4247
Reviewed-on: http://review.typo3.org/40541
Reviewed-by: Helmut Hummel <>
Tested-by: Helmut Hummel <>

History

#1 Updated by Gerrit Code Review over 4 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/38701

#2 Updated by Gerrit Code Review over 4 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/38701

#3 Updated by Gerrit Code Review over 4 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/38701

#4 Updated by Gerrit Code Review over 4 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/38701

#5 Updated by Gerrit Code Review over 4 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/38701

#6 Updated by Mathias Brodala over 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#7 Updated by Riccardo De Contardi almost 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF