Bug #67630

Loop when resolving circular relations

Added by Felix Oertel almost 4 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Must have
Assignee:
Category:
Extbase
Target version:
Start date:
2015-06-19
Due date:
% Done:

100%

TYPO3 Version:
7
PHP Version:
5.5
Tags:
Complexity:
easy
Is Regression:
No
Sprint Focus:

Description

When using circular relations in extbase

class Author has protected $articles and class Article has protected $author

the DataMappers attempt to resolv it will fail in an infinite loop.

Reason:
While replacing the IdentityMap with the PersistenceSession, the call responsible for registering the newly resolved object to the session was moved down too far. The object has to be registered before the arguments get mapped, so that sub-objects getting mapped can find it.


Related issues

Related to TYPO3 Core - Bug #66429: Remove IdentityMap Closed 2015-04-15
Duplicated by TYPO3 Core - Bug #67622: Recursion problem in extension with bidirectional IRRE records "Maximum function nesting level of X reached, aborting!" Closed 2015-06-19

Associated revisions

Revision 91d12569 (diff)
Added by Felix Oertel almost 4 years ago

[BUGFIX] Infinite loop with circular relations

When resolving circular relations, extbase fails with an
infinite loop because the DataMapper waits for all sub-
objects to be mapped before registering them to the session.
The sub-objects can thus not find the parent object in the
session and the loop begins.

Resolves: #67630
Related: #66429
Releases: master
Change-Id: Ie20e2690323a00d8f54f3af5ce2fce87715f4247
Reviewed-on: http://review.typo3.org/40471
Reviewed-by: Helmut Hummel <>
Tested-by: Helmut Hummel <>
Reviewed-by: Wouter Wolters <>
Reviewed-by: Nicole Cordes <>
Tested-by: Nicole Cordes <>

Revision 8fa7a66d (diff)
Added by Felix Oertel almost 4 years ago

[BUGFIX] Infinite loop with circular relations

When resolving circular relations, extbase fails with an
infinite loop because the DataMapper waits for all sub-
objects to be mapped before registering them to the session.
The sub-objects can thus not find the parent object in the
session and the loop begins.

Resolves: #67630
Related: #66429
Releases: master
Change-Id: Ie20e2690323a00d8f54f3af5ce2fce87715f4247
Reviewed-on: http://review.typo3.org/40541
Reviewed-by: Helmut Hummel <>
Tested-by: Helmut Hummel <>

History

#1 Updated by Gerrit Code Review almost 4 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/40471

#2 Updated by Gerrit Code Review almost 4 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/40471

#3 Updated by Gerrit Code Review almost 4 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/40471

#4 Updated by Anonymous almost 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#5 Updated by Gerrit Code Review almost 4 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_7-3 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/40541

#6 Updated by Anonymous almost 4 years ago

  • Status changed from Under Review to Resolved

#7 Updated by Riccardo De Contardi over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF