Feature #67229

FormEngine: The extendables

Added by Christian Kuhn about 4 years ago. Updated 10 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
FormEngine aka TCEforms
Target version:
-
Start date:
2015-06-01
Due date:
% Done:

100%

PHP Version:
5.5
Tags:
Complexity:
nightmare
Sprint Focus:

Related issues

Related to TYPO3 Core - Bug #67327: TCA Migrator issues deprecations for Core TCA Closed 2015-06-06
Related to TYPO3 Core - Bug #67328: TCA Migrator must not log deprecation if only syntax of TCA is adjusted Closed 2015-06-06
Related to TYPO3 Core - Bug #67429: RTE not loading while mass edit in list module Closed 2015-06-12

Associated revisions

Revision 0ee65b8f (diff)
Added by Christian Kuhn about 4 years ago

[!!!][FEATURE] FormEngine: The extendables

For details, see the ReST files with examples for new API
and TCA changes.

  • Split TCA config "type" to "type" and "renderType":
    TCA config "type" is a technical debt since it both defines the
    database storage as well as the widget that is used to render
    a certain field in FormEngine. While "type" is kept, the
    render widget is now extracted to a "renderType".
  • t3editor uses this "renderType" now. type=text with
    renderType=t3editor will call the new T3editorElement provided
    by ext:t3editor, and falls back to TextElement if t3editor is
    not loaded.
  • t3editor is now enabled for "setup" and "constants" of
    sys_template records if opening the whole record.
  • t3editor now works when configured in a flex form.
  • Introduce an API in FormEngine NodeFactory to register new
    renderType, used by t3editor.
  • Introduce a resolver API in FormEngine NodeFactory to change
    the class that renders a widget or container.
  • Split TextElement into TextElement that only renders a textarea
    and RichTextElement provided by ext:rtehtmlarea that renders RTE.
    ext:rtehtmlarea uses the new resolver API to route rendering to
    its own class in case RTE is enabled and configured for a field.
  • In TCA section "types" a new array "columnsOverrides" is
    introduced that allows overwriting some column configurations
    of fields. Currently, this works for some View/FormEngine related
    settings like renderType and defaultExtras.
  • TCA Migration is introduced to dynamically rewrite TCA before
    it is put into cache.
  • TCA migration is called a second time in ext:compatibility6 in
    case TCA is still registered via ext_tables.php. This has performance
    penalty since it is done on every frontend and backend call.
  • TCA migration is also called dynamically for flex form definitions.
  • TCA migration moves configured t3editor wizards to type=text with
    renderType=t3editor.
  • TCA migration removes the 5th parameter "style pointer" from
    types showitem
  • TCA migration moves the 4th showitem parameter "extra configuration"
    to "defaultExtras" of "columnsOverrides" of given TCA type.

Change-Id: Ia2c2bc16463a01021c7a6be765b4efa872a130fd
Resolves: #67229
Releases: master
Reviewed-on: http://review.typo3.org/39662
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>
Reviewed-by: Frank Nägler <>
Tested-by: Frank Nägler <>
Reviewed-by: Markus Klein <>
Tested-by: Markus Klein <>
Reviewed-by: Anja Leichsenring <>
Tested-by: Anja Leichsenring <>

Revision 5f85d0cb (diff)
Added by Frank Naegler about 4 years ago

[BUGFIX] RTE not loading while mass edit in list module

This patch fix a regression from FormEngine: The extendables patch.

Resolves: #67429
Related: #67229
Releases: master
Change-Id: I6a900e8ce8460440eb9feb146ada54ea8995112d
Reviewed-on: http://review.typo3.org/40205
Reviewed-by: Andreas Fernandez <>
Tested-by: Andreas Fernandez <>
Reviewed-by: Nicole Cordes <>
Tested-by: Nicole Cordes <>
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>

Revision ba4fc15d (diff)
Added by Christian Kuhn about 4 years ago

[BUGFIX] RTE transformation not executed

With moving the 4th TCA showitem field to defaultExtras in
columnsOverrides a bug was introduced, so the DataHandler no
longer executes RTE transformation. defaultExtras field
is parallel to config section, and not nested in there.

Resolves: #67614
Related: #67229
Releases: master
Change-Id: Ie6f21523ae3c63abbf69fd1623df92bec02e41fd
Reviewed-on: http://review.typo3.org/40467
Reviewed-by: Andreas Fernandez <>
Tested-by: Andreas Fernandez <>
Reviewed-by: Daniel Maier <>
Tested-by: Daniel Maier <>
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>

Revision a6f0b288 (diff)
Added by Christian Kuhn about 4 years ago

[BUGFIX] RTE transformation not executed

With moving the 4th TCA showitem field to defaultExtras in
columnsOverrides a bug was introduced, so the DataHandler no
longer executes RTE transformation. defaultExtras field
is parallel to config section, and not nested in there.

Resolves: #67614
Related: #67229
Releases: master
Change-Id: Ie6f21523ae3c63abbf69fd1623df92bec02e41fd
Reviewed-on: http://review.typo3.org/40540
Reviewed-by: Helmut Hummel <>
Tested-by: Helmut Hummel <>

History

#1 Updated by Gerrit Code Review about 4 years ago

  • Status changed from New to Under Review

Patch set 22 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/39662

#2 Updated by Gerrit Code Review about 4 years ago

Patch set 23 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/39662

#3 Updated by Gerrit Code Review about 4 years ago

Patch set 24 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/39662

#4 Updated by Gerrit Code Review about 4 years ago

Patch set 25 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/39662

#5 Updated by Gerrit Code Review about 4 years ago

Patch set 26 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/39662

#6 Updated by Gerrit Code Review about 4 years ago

Patch set 27 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/39662

#7 Updated by Gerrit Code Review about 4 years ago

Patch set 28 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/39662

#8 Updated by Gerrit Code Review about 4 years ago

Patch set 29 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/39662

#9 Updated by Gerrit Code Review about 4 years ago

Patch set 30 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/39662

#10 Updated by Gerrit Code Review about 4 years ago

Patch set 31 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/39662

#11 Updated by Christian Kuhn about 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#12 Updated by Benni Mack 10 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF