Bug #67348

RTE inserts <span class="line-height: xx"> in Chrome

Added by Simon Würstle over 6 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
RTE (rtehtmlarea + ckeditor)
Target version:
-
Start date:
2015-06-08
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

There have been some Bugs in Chrome (Webkit) with automatic inserted <span> tags which are already solved, but here is another one. Following simple scenario:

rte.css (RTE.default.contentCSS) with the only line: body { line-height: 1.4; }

Now insert one paragraph with text in the RTE field. Somewhere in the text press enter so there a two paragraphs afterwards. Leave the cursor on its position (beginning of second paragraph) and press backspace. In Chrome there is now a <span class="line-height: 1.4"> at the position where you pressed enter.

I figured out that this only happens if the line-height is set with a relative value (i.e. "1.4", "140%", "1.4em"). This bug does not occur if the value is in px-format (i.e. "14px").

Tested with TYPO3 CMS 6.2.12


Related issues

Related to TYPO3 Core - Bug #52470: In Chrome RTE inserts weird SPAN tagsClosedStanislas Rolland2013-10-02

Actions
Related to TYPO3 Core - Bug #59562: WebKit may insert a span element when backspacing an headingClosedStanislas Rolland2014-06-13

Actions
#1

Updated by Riccardo De Contardi over 4 years ago

  • Status changed from New to Closed

I tried to reproduce this one with TYPO3 7.6.21 and Chrome 64bit 60.0.3112.113, without luck.

I guess it is safe to close this for now (no activity since a lot of time and support for TYPO3 6.2.x ended - except for ELTS plans); if you think that this is the wrong decision or experience the issue again or have more information about how to reproduce it, then please reopein it or open a new issue with a reference to this one.

Thank you.

Also available in: Atom PDF