Bug #67359

Epic #55575: Streamline JavaScript Code in the TYPO3 Backend

Resolve the conflict between Bootstrap 3 and PrototypeJS in Backend

Added by Tobias Braumann over 6 years ago. Updated almost 6 years ago.

Status:
Rejected
Priority:
Must have
Assignee:
Category:
Miscellaneous
Target version:
Start date:
2015-06-09
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
5.6
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

I used the bootstrap dropdown button in my backend module and recognize a weird behavior. The button always disappear after clicking on it. After four hours trying to find a solution i found that the for that behavior relies on a conflict between bootstrap and PrototypeJS.

[[http://www.softec.lu/site/DevelopersCorner/BootstrapPrototypeConflict]]

The site describe the problem very well and offers two solutions. Please implement one of them. It seems to be that not only the dropdown function is affected.


Related issues

Related to TYPO3 Core - Feature #39721: Remove Prototype and script.aculo.us JavaScript librariesClosed2014-02-02

Actions
#1

Updated by Benni Mack over 6 years ago

  • Status changed from New to Accepted
  • Assignee set to Benni Mack
#2

Updated by Daniel Goerz over 6 years ago

#3

Updated by Susanne Moog about 6 years ago

  • Target version changed from 7.4 (Backend) to 7.5
#4

Updated by Benni Mack about 6 years ago

  • Target version changed from 7.5 to 7 LTS
#5

Updated by Benni Mack about 6 years ago

  • Category changed from Backend User Interface to Miscellaneous
  • Parent task set to #55575
#6

Updated by Frank Naegler about 6 years ago

  • Status changed from Accepted to Needs Feedback

can you please test again with current master? We use dropdown buttons (SplitButton) within the new DocHeaders. There is no problem.
If the problem still occurs, can you provide a demo extension?

#7

Updated by Benni Mack almost 6 years ago

  • Status changed from Needs Feedback to Rejected

This is fixed IMHO now. No problems anymore.

Also available in: Atom PDF