Bug #67622

Recursion problem in extension with bidirectional IRRE records "Maximum function nesting level of X reached, aborting!"

Added by Alex Kellner about 7 years ago. Updated about 7 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Extbase
Target version:
-
Start date:
2015-06-19
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
5.5
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Only relevant for TYPO3 7.3.0

If you are using an extensions together with extbase with parent and children records (e.g. with IRRE), it's no more possible to use bedirectional relations.

This worked like a charm in the past:

parent model

    /**
     * childrens
     *
     * @var \TYPO3\CMS\Extbase\Persistence\ObjectStorage<\Vendor\Ext\Domain\Model\Children>
     */
    protected $childrens;

children model

    /**
     * parent
     *
     * @var \Vendor\Ext\Domain\Model\Parent
     */
    protected $parent;

With 7.3 a nesting level error comes up.
Is this a bug or are you aware of this behaviour?

Related to #67539


Related issues

Is duplicate of TYPO3 Core - Bug #67630: Loop when resolving circular relationsClosedFelix Oertel2015-06-19

Actions
#1

Updated by Bernd Trippel about 7 years ago

67630 resolved the Issue for me.

#2

Updated by Helmut Hummel about 7 years ago

  • Status changed from New to Closed

closed as duplicate

Also available in: Atom PDF