Bug #68381

indexed_search placeholder for search field not replaced anymore

Added by Sven Carstens about 7 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Should have
Category:
Indexed Search
Target version:
Start date:
2015-07-20
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

The placeholder introduced in https://forge.typo3.org/issues/28347 is not replaced anymore in indexed_search 6.2.0

The rendered output for the search field is (with the standard template):
<input type="text" name="tx_indexedsearch[sword]" value="" class="tx-indexedsearch-searchbox-sword sword" />
Expected output is
<input type="text" name="tx_indexedsearch[sword]" value="" class="tx-indexedsearch-searchbox-sword sword" placeholder="Search for"/>

The template typo3_src/typo3/sysext/indexed_search/pi/template_css.tmpl still contains the placeholder ###PLACEHOLDER### (but has a linebreak within)
The language file typo3_src/typo3/sysext/indexed_search/pi/locallang.xlf still contains the value "default_search_word_entry"
The template typo3_src/typo3/sysext/indexed_search/pi/indexed_search.tmpl does not contain the placeholder
The controller typo3_src/typo3/sysext/indexed_search/Classes/Controller/SearchFormController.php does not replace the placeholder


Related issues

Related to TYPO3 Core - Feature #28347: Add HTML5 placeholder text to search form input fieldClosedMario Rimann2011-07-20

Actions
#1

Updated by Sebastian Schmal almost 7 years ago

fixed ?

#2

Updated by Tymoteusz Motylewski over 6 years ago

wow! it looks like it was removed from controller by mistake when merging 512b9c077 back in 17/11/2011.
see https://review.typo3.org/#/c/6657/

What version of TYPO3 have you used before in which it was working?

#3

Updated by Gerrit Code Review over 6 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/45220

#4

Updated by Gerrit Code Review over 6 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/45220

#5

Updated by Tymoteusz Motylewski over 6 years ago

  • Assignee set to Tymoteusz Motylewski
  • Target version set to 7.6.1
#6

Updated by Gerrit Code Review over 6 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/45220

#7

Updated by Gerrit Code Review over 6 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/45220

#8

Updated by Tymoteusz Motylewski over 6 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#9

Updated by Riccardo De Contardi almost 5 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF