Bug #68387

New Classes were not found while developing

Added by Stefan Froemken almost 6 years ago. Updated almost 6 years ago.

Status:
Rejected
Priority:
Should have
Assignee:
-
Category:
Caching
Target version:
Start date:
2015-07-20
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
5.6
Tags:
Complexity:
easy
Is Regression:
No
Sprint Focus:

Description

Hello,

for one of my new extensions I have just added a new Class called AbstractController. After clearing FE- and System-Cache this message still appears. Deleting the typo3temp/Cache directory does not help. Also composer.phar install and composer.phar update does not help.

Then I remember that there was a new directory "autoload" in typo3temp. After deleting that one, my FE-Output works again.

Would be cool to add that directory to Clear-System-Cache.

Stefan


Related issues

Is duplicate of TYPO3 Core - Bug #67996: Provide reasonable way to clear autoloader cachesClosed2015-07-09

Actions
#1

Updated by Frank Naegler almost 6 years ago

not for system cache, but a separate button in install tool is ok imo.

#2

Updated by Stefan Froemken almost 6 years ago

A separate Button?!?! For now we have 5 Clear Cache Buttons in our TYPO3 world and this is pretty much. I think and have seen that the most developers clears FE- und System-Cache while developing. I don't like the idea to have a third tab open, only to clear another cache. And don't forget the timeout of the InstallTool.

#3

Updated by Mathias Schreiber almost 6 years ago

Yes, a separate button.
Here's why:
An editor might clear system caches, with no need to rebuild autoloading caches.

Does this clear up things a bit? :)

#4

Updated by Stefan Froemken almost 6 years ago

Does your editors have access to clear system caches? I hope not. We have deactivated such configurations by default in core. Do you remember? So, an admin has to grant these rights explicit to a non-admin user. That's why I think, that combining these caches would be OK.
Else I will create my own little Welcome-Party for the 6th Clear Cache Button in TYPO3. Yeah ;-)

#5

Updated by Wouter Wolters almost 6 years ago

  • Status changed from New to Rejected

Rejected this ticket, continue in #67996 please. Thank you.

Also available in: Atom PDF