Bug #68448

t3editor: I miss the spaces after {

Added by Stefan Froemken almost 6 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
t3editor
Target version:
Start date:
2015-07-21
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
5.6
Tags:
Complexity:
Is Regression:
No
Sprint Focus:
Stabilization Sprint

Description

Hello,

page = PAGE
page.10 = TEXT
page.10 {
value

There are missing the two spaces before "value" like in all TYPO3 versions before.

Stefan


Related issues

Is duplicate of TYPO3 Core - Bug #66457: t3editor does not indent code with dot-syntax Closed2015-04-16

Actions
#1

Updated by Andreas Fernandez almost 6 years ago

  • Status changed from New to Closed

This seems to be a veeeery old bug in the TypoScript lexer. I'd like to target this bug for the LTS release, not for 7.4. As this is a dup of #66457, I'll close this ticket now.

#2

Updated by Gernot Ploiner over 5 years ago

This is not an old bug. It is since TYPO3 6.2.(i think 10 - not sure).
6.2.15 is better now.

This works fine:
page = PAGE
page {
10 = TEXT
10 {
value

But this still not:
page = PAGE
page.10 = TEXT
page.10 {
value

Summary: If you never use dots, it works.

I'm not sure, perhaps its a Firefox/Browser Problem and not a TYPO3-Problem?

Also available in: Atom PDF