Bug #68549

Refresh Login does not work

Added by Stefan Froemken almost 6 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend API
Target version:
Start date:
2015-07-27
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
5.6
Tags:
Complexity:
Is Regression:
No
Sprint Focus:
Stabilization Sprint

Description

Hello,

after BE login timeout the "Refresh Login to TYPO3 (User: froemken)" message appears. But it is not possible to relogin again. After some seconds a red message appear on the right side:

Login failed. Password not correct.

I have entered my password multiple time. I'm sure it is correct.

After changing the URL to the BE-Login I can login without any problems.

Stefan

#1

Updated by Frank Naegler almost 6 years ago

I think the problem is the moduleToken change, not verified yet, but we have some trouble since this change.

#2

Updated by Frank Naegler almost 6 years ago

Can't verify the problem, tested with FF and Chrome and 15 seconds session timeout.

#3

Updated by Stefan Froemken almost 6 years ago

Additional Information: OpenId is NOT activated

#4

Updated by Stefan Froemken almost 6 years ago

For your information:

I have set the BE-login timeout to 30 seconds. If you now constantly navigate through the Backend you will be logged out directly after 30 seconds. Seems that the timeout was not resetted to 0 with each request.

Stefan

#5

Updated by Wouter Wolters almost 6 years ago

Are you sure browser caches are empty, there was a change for ext:rsaauth that rewrote the JS part...

I cannot reproduce it here

#6

Updated by Markus Klein almost 6 years ago

There is a JS error in the "checkActiveSession" part.
The AJAX response does not report the "locked" state of the BE.

Will be fixed with #68554

#7

Updated by Nicole Cordes almost 6 years ago

  • Status changed from New to Needs Feedback

Please try with current master.

#8

Updated by Stefan Froemken almost 6 years ago

Ahh, there is an internal timer of 120 seconds. That's why it does not make sense to test with 15 or 30 seconds in Installtool for BE-timeout. I just have tested with 150 seconds and that looks much more stable. So, that issue can be closed now.

#9

Updated by Wouter Wolters almost 6 years ago

  • Status changed from Needs Feedback to Closed

thanks Stefan, closed now.

Also available in: Atom PDF