Feature #69478

Colored border for Backend layout

Added by Andreas Keck almost 4 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2015-09-02
Due date:
% Done:

0%

PHP Version:
Tags:
Complexity:
Sprint Focus:

Description

Provide an opportunity to colorize the border of backend layout area, like Gridelements.

On sites with many content areas on one page, this is really helpful

History

#1 Updated by Alexander Opitz almost 4 years ago

  • Category set to Backend User Interface
  • Status changed from New to Needs Feedback

You can colorize the background, does this fits your needs?

#2 Updated by Andreas Keck almost 4 years ago

Oh, I think this suffices. I don't know about this. On wich Version works this Feature and how is it documented?

Thanks Andreas

#3 Updated by Alexander Opitz almost 4 years ago

Hehe, I use this not very often, so I needed to search firstly a bit.

And my answer wasn't correct, you can not only colorize background you can also colorize the border, you can use every possibility of CSS. ;)
The Searchword for google is "inDocStyles_TBEstyle".

In short I use it like this in the ext_tables.php of the configuration extension for the customer:

$TBE_STYLES['inDocStyles_TBEstyle'] .= 'td.t3-page-column-99 {background-color: #00A000;}';

The number 99 is the colPos number you gave the column in your backend_layout configuration.

Does this information helps you?

#4 Updated by Markus Klein almost 4 years ago

  • Tracker changed from Feature to Task
  • Status changed from Needs Feedback to Accepted
  • Assignee set to Alexander Opitz
  • Target version set to 7 LTS
  • TYPO3 Version set to 6.2
  • Complexity set to easy

we should add a class which holds the BE layout uid as well. That is not a feature, but a small task only. (also for 6.2)

#5 Updated by Markus Klein almost 4 years ago

  • Tracker changed from Task to Feature
  • Assignee deleted (Alexander Opitz)
  • Target version changed from 7 LTS to 8 LTS
  • Complexity changed from easy to medium

Not that easy unfortunately. Backend layouts do not always have an id, so we first need to introduce some kind of identifier for layouts to make them addressable in CSS.

#6 Updated by Philipp Gampe almost 4 years ago

@Markus you always have an identifier, because this is the one that is also used to save to in the page record and to distinguish them during frontend rendering.

However it might be smarter to simply add a layout field.

#7 Updated by Alexander Opitz almost 4 years ago

  • Status changed from Accepted to Needs Feedback
  • Target version deleted (8 LTS)
  • Complexity deleted (medium)

@Philipp: The issue is, that we don't have it where we need this information. ;) And adding a layout field has the possibility to group them.

#8 Updated by Alexander Opitz almost 4 years ago

  • Status changed from Needs Feedback to Accepted

#9 Updated by Georg Ringer over 1 year ago

  • Status changed from Accepted to Closed

this won't be done on its alone but with the help of #84101, therefore I am closing it

Also available in: Atom PDF