Bug #69833

Processed files don't support not-local storages

Added by Nicole Cordes almost 6 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
Start date:
2015-09-15
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:
Stabilization Sprint

Description

Use case:

- a ftp storage (https://github.com/adgrafik/fal_ftp) marked as not writable with processing folder 1:/_processed_/FTP
- Text with image content record with an image from ftp storage

Problem:

- image isn't shown (neither in frontend nor backend)

Analysis:

- for frontend processing the driver creates a tempfile as the file on the other server isn't available for processing
- this is as defined in the function description of the DriverInterface
- the processing task tries to process (crop/mask) the image and confess there isn't any change needed
- the task returns NULL and the original file is used
- the processed file is saved with wrong information and the temp file is lost


Related issues

Related to TYPO3 Core - Bug #72554: f:image renders empty src attribute since 6.2.16Closed2016-01-06

Actions
#1

Updated by Gerrit Code Review almost 6 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/43338

#2

Updated by Gerrit Code Review almost 6 years ago

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/43364

#3

Updated by Anja Leichsenring almost 6 years ago

  • Sprint Focus changed from On Location Sprint to Stabilization Sprint
#4

Updated by Gerrit Code Review almost 6 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/43364

#5

Updated by Gerrit Code Review almost 6 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/43364

#6

Updated by Gerrit Code Review almost 6 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/43364

#7

Updated by Gerrit Code Review almost 6 years ago

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/43575

#8

Updated by Nicole Cordes almost 6 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#9

Updated by Riccardo De Contardi almost 4 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF