Bug #72554

f:image renders empty src attribute since 6.2.16

Added by Grégory Duchesnes over 3 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Fluid
Target version:
-
Start date:
2016-01-06
Due date:
% Done:

0%

TYPO3 Version:
6.2
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

Using the following code :

<f:image src="EXT:myext/Resources/Public/Css/gfx/flags/fr30.png" alt="" width="30" height="20" />

It renders correctly in 6.2.15 but since 6.2.16 it outputs with an empty src attribute :

<img width="30" height="20" alt="" src="">

File exists and everything works fine if i switch back to 6.2.15, tried with EXT: and full path without success, also tried without setting width and height attributes with same result.


Related issues

Related to TYPO3 Core - Bug #69833: Processed files don't support not-local storages Closed 2015-09-15

History

#1 Updated by Riccardo De Contardi over 3 years ago

  • Status changed from New to Needs Feedback

I am trying to reproduce it without success with 6.2.17; can you tell us more about your configuration?

- are the image manipulation tests in Install Tool working?
- is it working with a different path?
- is the path case sensitive?

You could also join the #typo3-cms channel in Slack if you need quick support.

Thank you

#2 Updated by Grégory Duchesnes over 3 years ago

All install tool tests are OK
Does not work with a different path either
Fails in both Mac Os X (non case sensitive) and linux Staging server (case sensitive)

#3 Updated by Riccardo De Contardi over 3 years ago

... and of course you removed all the cache from Install Tool...

ummm... I have exhausted the hints... can you upload your extension? I'll try with MAC OSX too...

#4 Updated by Grégory Duchesnes over 3 years ago

Of course i cleared all caches from the install tool.
Funny enough, images from RTE work as expected

My ext does not have anything special, it is just a bunch of templates and ViewHelpers. The only specific stuff is that i use fluidpages, fluidcontent, flux and vhs.

By the way, here follows my GFX config :

[colorspace]=RGB
[enable_typo3temp_db_tracking]=
[gdlib]=1
[gdlib_png]=0
[gif_compress]=1
[im]=1
[imagefile_ext]=gif,jpg,jpeg,tif,tiff,bmp,pcx,tga,png,pdf,ai
[image_processing]=1
[im_combine_filename]=composite
[im_imvMaskState]=1
[im_mask_temp_ext_gif]=1
[im_noFramePrepended]=
[im_noScaleUp]=1
[im_path]=/opt/local/bin/
[im_path_lzw]=/opt/local/bin/
[im_stripProfileCommand]=+profile '*'
[im_useStripProfileByDefault]=1
[im_v5effects]=1
[im_version_5]=gm
[jpg_quality]=85
[png_truecolor]=1
[thumbnails]=1
[thumbnails_png]=0
[TTFdpi]=96

#5 Updated by Grégory Duchesnes over 3 years ago

I couldn't find any clue either so i did something basic : i gradually replaced parts of 6.2.15 core with 6.2.17 bits and i found out that typo3/sysext/core/Classes/Resource/ProcessedFile.php->getPublicUrl extends typo3/sysext/core/Classes/Resource/AbstractFile.php->getPublicUrl and adds a test on $this->usesOriginalFile().

Removing this test makes everything work again.

Does this help?

#6 Updated by Riccardo De Contardi over 3 years ago

This is mine:

         'colorspace' => 'RGB',
        'im' => 1,
        'im_mask_temp_ext_gif' => 1,
        'im_path' => '/usr/local/bin/',
        'im_path_lzw' => '/usr/local/bin/',
        'im_v5effects' => -1,
        'im_version_5' => 'gm',
        'image_processing' => 1,
        'jpg_quality' => '80',

I used flux, fluidpages, fluidcontent, vhs too...
I don't know what else to say... As I said, I could not reproduce...maybe someone else can reproduce it?

#7 Updated by Riccardo De Contardi over 3 years ago

  • Status changed from Needs Feedback to New

#8 Updated by Grégory Duchesnes over 3 years ago

could it be related to #71686 ?

#9 Updated by Grégory Duchesnes over 3 years ago

bug still present in 6.2.19

Edit : i just noticed that news images work as well. So to sum up, any image tag using FAL works but fails if you specify a path in src attribute

#10 Updated by Oliver Hader over 3 years ago

  • Status changed from New to Needs Feedback
  • Priority changed from Must have to Should have
To sum it up (please correct, if wrong):
  • using image of file-list (FAL image): works
  • using path: does not work (which is quite obvious)
  • using string with "EXT:" prefix as identifier: does not work

#11 Updated by Grégory Duchesnes over 3 years ago

summary is correct but i do not understand the comment "(which is quite obvious)" and the fact that the issue is downgraded from "must have" to "should have". My site can not be upgraded anymore but it is not an issue for you?

#12 Updated by Grégory Duchesnes over 3 years ago

Hi Oliver, could you please Reply on your previous comment?

#13 Updated by Grégory Duchesnes over 3 years ago

By the way : upgrade PHP version from 5.3 to 5.5 does not change anything

#14 Updated by Riccardo De Contardi about 3 years ago

  • Status changed from Needs Feedback to New

#15 Updated by Frans Saris almost 3 years ago

The `<f:image src="EXT:...." />` still works on 7.6.

Did you already try this with a different/new static file. Did you try to clear all processed files in install tool?

#16 Updated by Grégory Duchesnes almost 3 years ago

I did try to clear all caches i could think of :
- cache_* and cf_* tables
- install tool clear cache and clear opcode cache
- _processed, pics, Cache folders in typo3temp

nothing works with any picture but i found something : it does not work if i set the exact size of my file :

<f:image src="EXT:myExt/Resources/Public/Css/gfx/logo.png" width="152" height="89" alt="myAlt" />

but it works (and image is off course ugly) if i change width or height (therefore image is being stretched by TYPO3 and found in _processed folder) :

<f:image src="EXT:myExt/Resources/Public/Css/gfx/logo.png" width="152" height="88" alt="myAlt" />

This is wrong behaviour. TYPO3 should be able to use images without touching them

#17 Updated by Riccardo De Contardi over 2 years ago

I am still not able to reproduce it with 6.2.30

#18 Updated by Georg Ringer over 1 year ago

  • Status changed from New to Closed

closed because of lack of feedback.

Also available in: Atom PDF