Bug #69949

TypoScript: page.inlineLanguageLabel throws a fatal error in frontend

Added by Thomas Deuling about 6 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
TypoScript
Target version:
-
Start date:
2015-09-18
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
5.6
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Hi,
the following TypoScript:

page.inlineLanguageLabel {
    languageMenu_label = Language menu
}

throws a fatal error in frontend

( ! ) Fatal error: Call to a member function sL() on null in /var/www/..../htdocs/typo3/sysext/core/Classes/Page/PageRenderer.php on line 1614
Call Stack
#    Time    Memory    Function    Location
1    0.0001    251880    {main}( )    .../index.php:0
2    0.0001    252288    call_user_func:{/var/www/..../htdocs/index.php:34} ( )    .../index.php:34
3    0.0001    252328    {closure:/var/www/..../htdocs/index.php:31-34}( )    .../index.php:34
4    0.0191    3387584    TYPO3\CMS\Frontend\Http\Application->run( )    .../index.php:33
5    0.0220    3510184    TYPO3\CMS\Core\Core\Bootstrap->handleRequest( )    .../Application.php:76
6    0.0226    3524040    TYPO3\CMS\Frontend\Http\RequestHandler->handleRequest( )    .../Bootstrap.php:288
7    0.6469    9837928    TYPO3\CMS\Frontend\Page\PageGenerator::renderContent( )    .../RequestHandler.php:213
8    1.0025    12606008    TYPO3\CMS\Frontend\Page\PageGenerator::renderContentWithHeader( )    .../PageGenerator.php:218
9    1.0078    12676856    TYPO3\CMS\Core\Page\PageRenderer->addInlineLanguageLabelArray( )    .../PageGenerator.php:881

TYPO3: 7.4
PHP: 5.6.13-1~dotdeb+7.1


Related issues

Is duplicate of TYPO3 Core - Bug #70681: Call to a member function sL() on a non-object in PageRenderer.phpClosed2015-10-14

Actions
#1

Updated by Riccardo De Contardi almost 6 years ago

  • Status changed from New to Needs Feedback

Can you try with the latest master (7.6) or could you give us further informations about how to reproduce this issue?

I just tried with 7.6-dev on MAMP enviroment (PHP 5.6.10) and I had no error

Thank you!

#2

Updated by Riccardo De Contardi almost 6 years ago

  • Category set to TypoScript
#3

Updated by Georg Ringer almost 6 years ago

  • Status changed from Needs Feedback to Resolved

resolved with #70681

#4

Updated by Benni Mack about 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF