Bug #70314

Flexform fields of first sheet with displayCond and multiple sheets will not be displayed

Added by Stefan Froemken almost 4 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Should have
Category:
DataHandler aka TCEmain
Target version:
Start date:
2015-10-02
Due date:
% Done:

100%

TYPO3 Version:
7
PHP Version:
5.6
Tags:
Complexity:
easy
Is Regression:
No
Sprint Focus:

Description

Hello Core-Team,

I have a FlexForm with two sheets.
First sheet has some fields with a given displayCond to another field which as also on first page.
I have checked it multiple times, the values are equal, but the field will not be displayed.

The problem is in EvaluateDisplayConditions::removeFlexformFields()

On first loop over the first sheet, the $result is OK.
On second loop over the second sheet, it has only the field values of second sheet, but it validates the displayConds of first sheet again. With no data for first sheet all conditions of first sheet will now be FALSE.

We have to stop the duplicated validation.

I have an idea where to solve that and will push a patch now.

Stefan

Associated revisions

Revision 00f5c62a (diff)
Added by Stefan Froemken almost 4 years ago

[BUGFIX] FormEngine: Only evaluate Flexform display conditions once

Avoid evaluating the display conditions for fields on a Flexform sheet
more than once. Multiple evaluations of the same conditions can lead to
wrong result due to fields having been removed by the first evaluation.

Resolves: #70314
Releases: master
Change-Id: I412a8cc2acf67e2a72de1f37a0f8038110ca4c2e
Reviewed-on: http://review.typo3.org/43744
Reviewed-by: Morton Jonuschat <>
Tested-by: Morton Jonuschat <>
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>

History

#1 Updated by Gerrit Code Review almost 4 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/43744

#2 Updated by Gerrit Code Review almost 4 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/43744

#3 Updated by Gerrit Code Review almost 4 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/43744

#4 Updated by Gerrit Code Review almost 4 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/43744

#5 Updated by Stefan Froemken almost 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#6 Updated by Philipp Wrann over 3 years ago

It seems this is not resolved, i have a flexform displaying 3 sheets and displayConditions do only work on the first sheet.

If i move all displayConditions to another sheet than the first they will not work.

Typo3 Version = 7.6 (LTS)

#7 Updated by Christian Fries over 2 years ago

Agreed, display conditions for fields that are not on the first sheet don't work. If I move the fields to the first sheet, the exact same display conditions work.

#8 Updated by Riccardo De Contardi almost 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF