Project

General

Profile

Actions

Bug #70435

closed

Story #69617: FormEngine bugs

IRRE foreign_selector with useCombination on save does not update label in select list of foreign_selector

Added by Andreas Allacher almost 9 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend API
Target version:
Start date:
2015-10-06
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

1.) Using foreign_selector with useCombination
2.) title of the foreign_selector contains a field form the combined table.
3.) Modifying field that contains table via IRRE in useCombination mode
4.) Save (not Save+Close)

This will result in the title in the foreign_selector being the old title. Saving again or Save+Close and reopening works fine.


Related issues 1 (0 open1 closed)

Related to TYPO3 Core - Task #69749: Introduce caching for record titlesClosedNicole Cordes2015-09-13

Actions
Actions #1

Updated by Christian Kuhn almost 9 years ago

target for a fix after https://review.typo3.org/#/c/43755/ was finished and merged, not before.

Actions #2

Updated by Christian Kuhn almost 9 years ago

  • Parent task set to #69617

still an issue currently?

Actions #3

Updated by Andreas Allacher almost 9 years ago

Yes, I still have this issue.
Only on the second save or reloading after save or save & exit and reopening works.

Forgot to put ticket on watch.
Is there a way in forge to automatically put created tickets on watch? I couldn't find anything in the settings.

Actions #4

Updated by Christian Kuhn almost 9 years ago

confirmed. reproducible with ext:styleguide inline_3 if 'foreign_unique' => 'select_child' is commented. I'd guess this is due to the caching in BackendUtility::getRecordTitle, but didn't dig deeper, yet.

Actions #5

Updated by Christian Kuhn over 8 years ago

confirmed, this is the getRecordTitle() cache ... i'll revert this cache for now ...

Actions #6

Updated by Gerrit Code Review over 8 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/44241

Actions #7

Updated by Gerrit Code Review over 8 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/44241

Actions #8

Updated by Christian Kuhn over 8 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #9

Updated by Riccardo De Contardi over 6 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF