Bug #70786

Story #69712: Further FormEngine development

FlexForm-based column is missing validation and transfer

Added by Xavier Perseguers about 5 years ago. Updated about 5 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
FormEngine aka TCEforms
Target version:
Start date:
2015-10-16
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
5.6
Tags:
Complexity:
Is Regression:
No
Sprint Focus:
Remote Sprint

Description

When your TCA has such definition:

        'rulesets' => array(
            'label' => 'LLL:EXT:image_autoresize/Resources/Private/Language/locallang_tca.xlf:tx_imageautoresize.rulesets',
            'config' => array(
                'type' => 'flex',
                'ds_pointerField' => 'list_type',
                'ds' => array(
                    'default' => 'FILE:EXT:image_autoresize/Configuration/FlexForms/Rulesets.xml',
                ),
            ),
        ),

FormEngine is properly showing the container and everything seems to work properly (add/delete/move):

However the validation on fields of the child form (input text, max length, ...) is not invoked right after adding a new child (this is the first bug, not that bad at first sight) but the transfer from form fields to corresponding hidden fields does not happen either, making the submitted form totally empty on save, showing an empty child on reload and only then "working" as expecting.

To easily reproduce/debug, just install EXT:image_autoresize (from git repository) and apply https://review.typo3.org/#/c/44062, then go to EM and click on the title to configure the extension, under "Rule Sets" (last tab), you see such a definition of FlexForm-based record.

I tried the same with a standard TCA (not "hacking" for standalone FormEngine) and the problem is the same, so it's not related to standalone FormEngine.


Files

tca.png (9.71 KB) tca.png Xavier Perseguers, 2015-10-16 12:11

Related issues

Related to Resize images automatically - Bug #70201: Fatal error: Class 'TYPO3\CMS\Backend\Form\FormEngine'ClosedXavier Perseguers2015-09-30

Actions
Is duplicate of TYPO3 Core - Bug #69383: Flexform input field not saved on first saveClosed2015-08-28

Actions
#1

Updated by Christian Kuhn about 5 years ago

  • Parent task set to #69712
#2

Updated by Mathias Schreiber about 5 years ago

  • Status changed from New to Closed

Also available in: Atom PDF