Bug #70859

Story #69617: FormEngine bugs

IRRE fields in flexforms don't show existing records

Added by Sebastian Michaelsen almost 4 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
FormEngine aka TCEforms
Target version:
Start date:
2015-10-20
Due date:
% Done:

100%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

When rendering IRRE fields (like a FAL field) inside flexforms no existing records are shown.

This bug occurs since lolli's IRRE refactoring commit https://github.com/TYPO3/TYPO3.CMS/commit/efa8c85dafc5667489f3f22e57fc258984f26770

Associated revisions

Revision b2d87462 (diff)
Added by Morton Jonuschat almost 4 years ago

[BUGFIX] FormEngine: Fix IRRE handling in flexforms

This patchset solves multiple problems with handling IRRE within a
FlexForm:

  • creating new records no longer triggers an internal server error
    due to missing parent data
  • IRRE children are passed to the renderer so that they get displayed
    in the backend
  • child table is determined correctly within flexforms when toggling
    expand/collapse state.

Resolves: #70918
Resolves: #70859
Releases: master
Change-Id: I93abeab696fff356453f0a1c305a8cfeede7158c
Reviewed-on: https://review.typo3.org/44579
Reviewed-by: Frank Nägler <>
Tested-by: Frank Nägler <>
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>

History

#1 Updated by Sebastian Michaelsen almost 4 years ago

  • Category set to FormEngine aka TCEforms

#2 Updated by Andreas Fernandez almost 4 years ago

  • Target version set to 7 LTS

#3 Updated by Morton Jonuschat almost 4 years ago

  • Parent task set to #69617

#4 Updated by Gerrit Code Review almost 4 years ago

  • Status changed from New to Under Review

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/44579

#5 Updated by Gerrit Code Review almost 4 years ago

Patch set 8 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/44579

#6 Updated by Gerrit Code Review almost 4 years ago

Patch set 9 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/44579

#7 Updated by Morton Jonuschat almost 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#8 Updated by Riccardo De Contardi almost 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF