Project

General

Profile

Actions

Bug #71322

closed

Story #69617: FormEngine bugs

Flexform: section contents not saved on first save

Added by Christian Weiske over 8 years ago. Updated almost 7 years ago.

Status:
Closed
Priority:
Should have
Category:
FormEngine aka TCEforms
Target version:
Start date:
2015-11-04
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

I've got a flexform section which I can add elements to.
Adding an element, filling out its fields and saving throws away the field values.

The section element itself is still there and I can fill it and save the values fine.
Just on the first save the data are thrown away.

Happens with TYPO3 7.5, flux 7.2.3 and fluidcontent 4.3.3

Reported bugs for flux:

Minimal fluidcontent example element:

<?xml version="1.0" encoding="utf-8"?>
<html xmlns="http://www.w3.org/1999/xhtml" lang="en" 
     xmlns:f="http://typo3.org/ns/TYPO3/Fluid/ViewHelpers" 
     xmlns:flux="http://typo3.org/ns/FluidTYPO3/Flux/ViewHelpers">
  <f:layout name="Content" />

  <f:section name="Configuration">
    <flux:form id="test" options="{group: 'FCE'}">
      <flux:form.section name="settings.links" label="Links">
        <flux:form.object name="link" label="Link">
          <flux:field.input name="url" label="URL"/>
        </flux:form.object>
      </flux:form.section>
    </flux:form>
  </f:section>
</html>

Attached is a screenshot how the form looks like after the first saving.


Files

Actions #1

Updated by Christian Kuhn over 8 years ago

confirmed, but does not always happen:

ext:styleguide
flex_2
1 Sub elements, add, put content into type input -> not saved
2 sub elements, add, put content into type text -> correctly saved

Actions #2

Updated by Christian Kuhn over 8 years ago

  • Category set to FormEngine aka TCEforms
  • Target version set to 7 LTS
  • Parent task set to #69617
Actions #3

Updated by Morton Jonuschat over 8 years ago

Seems to happen for field types that are split into a hidden input and a „human readable“ input.

Actions #4

Updated by Morton Jonuschat over 8 years ago

  • Status changed from New to Accepted
  • Assignee set to Morton Jonuschat
Actions #5

Updated by Morton Jonuschat over 8 years ago

  • Status changed from Accepted to In Progress
Actions #6

Updated by Gerrit Code Review over 8 years ago

  • Status changed from In Progress to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/44565

Actions #7

Updated by Gerrit Code Review over 8 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/44565

Actions #8

Updated by Morton Jonuschat over 8 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #9

Updated by Riccardo De Contardi almost 7 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF