Bug #71567

Bug #72932: PHP Warning: Incompatible method declaration in Extbase

FAL FileReference

Added by Frank Buijze almost 4 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Start date:
2015-11-13
Due date:
% Done:

0%

TYPO3 Version:
7
PHP Version:
7.0
Tags:
PHP7
Complexity:
Is Regression:
No
Sprint Focus:

Description

The following error occurs when switching from PHP 5.6 to PHP 7 in combination with TYPO3 7.6 LTS

1: PHP Warning: Declaration of TYPO3\CMS\Extbase\Domain\Model\FileReference::setOriginalResource(TYPO3\CMS\Core\Resource\FileReference $originalResource) should be compatible with TYPO3\CMS\Extbase\Domain\Model\AbstractFileFolder::setOriginalResource(TYPO3\CMS\Core\Resource\ResourceInterface $originalResource) in ***/typo3_src-7.6.0/typo3/sysext/extbase/Classes/Domain/Model/FileReference.php line 22

History

#1 Updated by Riccardo De Contardi almost 4 years ago

  • Category set to File Abstraction Layer (FAL)

#2 Updated by Alexander Opitz almost 4 years ago

  • Status changed from New to Accepted
  • Assignee set to Alexander Opitz
  • Target version changed from 7 LTS to Candidate for patchlevel

#3 Updated by Michael Oehlhof over 3 years ago

How is it to reproduce?

#4 Updated by Frank Buijze over 3 years ago

Michael Oehlhof wrote:

How is it to reproduce?

Basic use of File Reference in combination with PHP 7. I experienced this error during the development of a plugin fro Typo3. Issue does not exist in earlier versions of PHP

#5 Updated by Philipp Faber over 3 years ago

Is there a fix or workaround for this? I just took a a whole installation and moved it to another server that runs PHP7 and now I get this error.

#6 Updated by Michael Oehlhof over 3 years ago

  • Status changed from Accepted to Closed
  • Assignee deleted (Alexander Opitz)
  • Parent task set to #72932

Duplicate of 72932

Also available in: Atom PDF