Bug #71917

Deprecate second argument in getLL/ sL which HTML encodes the label

Added by Helmut Hummel about 5 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Code Cleanup
Target version:
Start date:
2015-12-17
Due date:
% Done:

100%

Estimated time:
(Total: 0.00 h)
TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

HTML encoding does not belong in a localisation API and should completely be removed.

Instead htmlspecialchars should be called where appropriate


Subtasks

Bug #72280: EXT:backend: Use htmlspecialchars instead of 2nd Parameter in getLL/sLClosedMichael Oehlhof2015-12-17

Actions
Task #76321: Remove second parameter of getLLClosedWouter Wolters2016-05-27

Actions
Task #76325: Remove second parameter of sLClosedValentin Despa2016-05-27

Actions
#1

Updated by Georg Ringer almost 5 years ago

  • Status changed from New to Accepted
#2

Updated by Riccardo De Contardi over 4 years ago

  • Category set to Code Cleanup
#3

Updated by Gerrit Code Review over 4 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/48353

#4

Updated by Gerrit Code Review over 4 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/48353

#5

Updated by Gerrit Code Review over 4 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/48353

#6

Updated by Anonymous over 4 years ago

  • Status changed from Under Review to Resolved
#7

Updated by Riccardo De Contardi about 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF