Bug #72110

flux was requested to be downloaded in different versions (7.2.3 and 7.3.0)

Added by Stephan Bauer almost 6 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Extension Manager
Target version:
-
Start date:
2015-12-08
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

I have installed flux 7.1.2 and the corresponding fluidpages, fluidcontent ...
Since the release of flux 7.3.0 I'm getting the error
"flux was requested to be downloaded in different versions (7.2.3 and 7.3.0)"

The error can be reproduced with only flux 7.1.2 and fluidpages 3.1.2.
No other extensions installed.

After deleting flux 7.3.0 in tx_extensionmanager_domain_model_extension everythings works


Related issues

Related to TYPO3 Core - Bug #66152: Distribution: Can not install distributions that depend on older extensionsRejected2015-03-30

Actions
Related to TYPO3 Core - Bug #72570: extension manager auto updates extension to false incompatible version Closed2016-01-07

Actions
#1

Updated by Riccardo De Contardi almost 6 years ago

I've got the same error on 6.2.15

#2

Updated by Andreas Fernandez almost 6 years ago

  • Status changed from New to Needs Feedback

Can you please check whether there is a conflict in those extensions depending on flux? It looks to me one ext requires flux 7.3.0 and another ext requires flux 7.2.3.

#3

Updated by Stephan Bauer almost 6 years ago

Hello Andreas,
maybe it was not clear what I wrote. I could reproduce this problem with only flux 7.1.2 and fluidpages 3.1.2 and no other extensions installed. fluidpages 3.1.2 has the dependency 'flux' => '7.1.0-7.1.99',

#4

Updated by Andreas Bouche almost 6 years ago

A customer of ours gets the same error concerning powermail 2.1.17 and 2.19.0, also on TYPO3 6.2.15.

#5

Updated by Arne-Kolja Bachstein almost 6 years ago

Maybe a problem in the repository?

I am getting the exactly same error on an upgrade from 6.1 to 6.2.15, without any updates of extensions. Occurs after updating the repo infos, not after changing extensions.

For testing purposes I removed the newest entries of flux from tx_extensionmanager_domain_model_extension and it works again.

Maybe a problem with the upload of the latest flux update?

#6

Updated by swanage no-lastname-given almost 6 years ago

I can confirm this error.
It happened to me in 6.2.15 just after updating repo info.

#7

Updated by Jozef Spisiak almost 6 years ago

I can confirm same error, also went through all ext_emconf and only lines with flux we have are these:
'flux' => '7.1.0-7.1.99',
'flux' => '',

we are running 7.1.0 flux right now.

#8

Updated by Stephan Bauer almost 6 years ago

It seems to be fixed in 6.2.16

#9

Updated by Morton Jonuschat almost 6 years ago

  • Status changed from Needs Feedback to Closed
  • Target version deleted (6.2.16)

As the problem was fixed for the issue creator and no one else said anything different I'll close this one.

If you think that this is the wrong decision or experience this issue again, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

#10

Updated by Marc Blasig over 5 years ago

We got a similar problem today: flux was requested to be downloaded in different versions (7.3.0 and 7.4.0).
Clearing tx_extensionmanager_domain_model_extension fixed the fatal error but also results in not being able to fetch from TER anymore.
Flux Version is 7.2.3, any ideas?

#11

Updated by Marc Willmann over 5 years ago

Similar problem as described from Marc Blasig here on a dev system which wasn't updated for a while after pulling the extension list from TER. Fixed with TRUNCATING tx_extensionmanager_domain_model_extension and updating the core to 6.2.25 and clearing all caches. Seems to be okay for me right for the moment.

Also available in: Atom PDF