Bug #72200

Bug #71298: Fix missing/broken RTE features after Link Handler API merge

Folder selection wizard uses wrong syntax for selected value

Added by Antoine Bouet over 3 years ago. Updated 5 months ago.

Status:
Resolved
Priority:
Must have
Assignee:
-
Category:
Link Handling, Site Handling & Routing
Target version:
Start date:
2015-12-14
Due date:
% Done:

0%

TYPO3 Version:
7
PHP Version:
5.6
Tags:
Complexity:
medium
Is Regression:
Yes
Sprint Focus:
On Location Sprint

Description

Hi all,

With this code above, the wizard create the string "file:1:/user_upload/my_folder/" in the field.
But when I save the content, nothing is saved.

If I put manually "/user_upload/my_folder/", it works.

Why ? :(

<?xml version="1.0" encoding="utf-8" standalone="yes" ?>
<T3DataStructure>
    <meta>
        <langDisable>1</langDisable>
    </meta>
    <sheets>
        <sDEF>
            <ROOT>
                <TCEforms>
                    <sheetTitle>LLL:EXT:my_ext/Resources/Private/Language/locallang_db.xlf:flexforms_tab.settings</sheetTitle>
                </TCEforms>
                <type>array</type>
                <el>
                    <settings.folder>
                        <TCEforms>
                            <label>LLL:EXT:my_ext/Resources/Private/Language/locallang_db.xlf:flexform.folder</label>
                            <config>
                                <type>input</type>
                                <size>30</size>
                                <eval>trim</eval>
                                <wizards>
                                    <_PADDING>2</_PADDING>
                                    <link>
                                        <type>popup</type>
                                        <title>Link</title>
                                        <icon>link_popup.gif</icon>
                                        <module type="array">
                                            <name>wizard_element_browser</name>
                                            <urlParameters type="array">
                                                <mode>wizard</mode>
                                                <act>folder</act>
                                            </urlParameters>
                                        </module>
                                        <params>
                                            <blindLinkOptions>page,file,mail,url,spec</blindLinkOptions>
                                        </params>
                                        <JSopenParams>height=500,width=500,status=0,menubar=0,scrollbars=1</JSopenParams>
                                    </link>
                                </wizards>
                            </config>
                        </TCEforms>
                    </settings.folder>
                </el>
            </ROOT>
        </sDEF>
    </sheets>
</T3DataStructure>

Related issues

Related to TYPO3 Core - Feature #73195: Automatically select the previously opened folder when creating a link to a file New 2016-02-09

History

#1 Updated by Morton Jonuschat over 3 years ago

  • Status changed from New to Needs Feedback

Could you try 1:/user_upload/my_folder/ as value. For a folder file: at the beginning is not correct, it should be the ID of the storage.

#2 Updated by Antoine Bouet over 3 years ago

Thanks for your reply.

I know that it works, but if my contributor use a wizard, the selected value should be automatically the good one.
It will be complicated to explain that is a normal behaviour :(

Is it possible to display the right syntax at the first time ? Or can I do it with an another config ?

#3 Updated by Morton Jonuschat over 3 years ago

  • Category changed from FormEngine aka TCEforms to Link Handling, Site Handling & Routing
  • Status changed from Needs Feedback to New
  • Target version set to Candidate for patchlevel

This seems to be a bug in the handling of folders in the FileLinkHandler

#4 Updated by Morton Jonuschat over 3 years ago

  • Subject changed from Flexform : folder selection wizard not saved to Folder selection wizard uses wrong syntax for selected value

#5 Updated by Gerrit Code Review over 3 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/45347

#6 Updated by Gerrit Code Review over 3 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/45347

#7 Updated by Gerrit Code Review over 3 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/45347

#8 Updated by Gerrit Code Review over 3 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/45347

#9 Updated by Gerrit Code Review over 3 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/45347

#10 Updated by Morton Jonuschat over 3 years ago

  • Status changed from Under Review to New
  • Target version deleted (Candidate for patchlevel)

#11 Updated by Morton Jonuschat over 3 years ago

Initial patch abandoned as it didn't solve the problem

#12 Updated by Markus Klein about 3 years ago

  • Assignee set to Markus Klein
  • Target version set to 7.6.3
  • Complexity set to medium
  • Is Regression changed from No to Yes

#13 Updated by Markus Klein about 3 years ago

  • Target version changed from 7.6.3 to Candidate for patchlevel
  • Sprint Focus set to Stabilization Sprint

#14 Updated by Markus Klein about 3 years ago

  • Target version changed from Candidate for patchlevel to 7.6.5

#15 Updated by Antoine Bouet almost 3 years ago

This problem still exists in Typo3 7.6.9

#16 Updated by Markus Klein almost 3 years ago

  • Target version changed from 7.6.5 to next-patchlevel

#17 Updated by Markus Klein over 2 years ago

  • Parent task set to #71298

#18 Updated by Susanne Moog 5 months ago

  • Sprint Focus changed from Stabilization Sprint to On Location Sprint

#19 Updated by Anja Leichsenring 5 months ago

  • Status changed from New to Resolved
  • Assignee deleted (Markus Klein)

works nicely in v8 and v9. I close the issue for this reason.

Also available in: Atom PDF