Feature #72744

Install Tool should warn about wrong/absent Imagemagick configuration on the tab 'Important actions'

Added by Franz Holzinger almost 5 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Install Tool
Target version:
-
Start date:
2016-01-15
Due date:
% Done:

0%

Estimated time:
PHP Version:
Tags:
Complexity:
Sprint Focus:

Description

All images are shown in full size after an upgrade to TYPO3 6.2.17.

Franz Holzinger wrote:"
However the "TRUNCATE sys_file_processed" could solve the problem here.
"

Frans Saris wrote: "
Is already part of the upgrade process (one of the upgrade wizards)
"

This still does not work. All the upgrade steps in the Install Tool are missing the truncate of the table sys_file_processed. Therefore all the images are shown in full size in the Frontend.


Related issues

Related to TYPO3 Core - Bug #61181: FAL: file maxW and maxH are ignoredRejected2014-08-25

Actions
Related to TYPO3 Core - Feature #62210: Issue warning in install tool if image manipulation is not availableClosed2014-10-14

Actions
#1

Updated by Wouter Wolters almost 5 years ago

  • Status changed from New to Needs Feedback

Franz, I think Frans ment another wizard that is available in the Install Tool but is not an upgrade wizard.

Under "Clean up -> Clear processed files" you can clear the sys_file_processed table.

Could you try this?

#2

Updated by Franz Holzinger almost 5 years ago

Yes. I press the button "Clear processed files", then the table sys_file_processedfile is cleared. Then I reload the Front End. However the images are still in full size. No change at all.

I do not know why this does not work anymore. I have tried this on a 1:1 copy of the other TYPO3 site where I have managed to get the images into the correct size.

I have also done some deletion of fields with the database analyzer.


Drop fields (really!)

    select/deselect all
    ALTER TABLE sys_file DROP zzz_deleted_crdate;
    ALTER TABLE sys_file DROP zzz_deleted_cruser_id;
    ALTER TABLE sys_file DROP zzz_deleted_deleted;
    ALTER TABLE sys_file DROP zzz_deleted_t3ver_oid;
    ALTER TABLE sys_file DROP zzz_deleted_t3ver_id;
    ALTER TABLE sys_file DROP zzz_deleted_t3ver_wsid;
    ALTER TABLE sys_file DROP zzz_deleted_t3ver_label;
    ALTER TABLE sys_file DROP zzz_deleted_t3ver_state;
    ALTER TABLE sys_file DROP zzz_deleted_t3ver_stage;
    ALTER TABLE sys_file DROP zzz_deleted_t3ver_count;
    ALTER TABLE sys_file DROP zzz_deleted_t3ver_tstamp;
    ALTER TABLE sys_file DROP zzz_deleted_t3ver_move_id;
    ALTER TABLE sys_file DROP zzz_deleted_t3_origuid;
    ALTER TABLE sys_file DROP zzz_deleted_title;
    ALTER TABLE sys_file DROP zzz_deleted_width;
    ALTER TABLE sys_file DROP zzz_deleted_height;
    ALTER TABLE sys_file DROP zzz_deleted_description;
    ALTER TABLE sys_file DROP zzz_deleted_alternative;
    ALTER TABLE sys_file_processedfile DROP zzz_deleted_pid;
    ALTER TABLE sys_file_processedfile DROP zzz_deleted_cruser_id;
    ALTER TABLE sys_file_processedfile DROP zzz_deleted_deleted;
    ALTER TABLE sys_file_processedfile DROP zzz_deleted_context;
    ALTER TABLE sys_file_processedfile DROP zzz_deleted_is_processed;
    ALTER TABLE sys_file_processedfile DROP zzz_deleted_extension;
    ALTER TABLE sys_file_processedfile DROP zzz_deleted_mime_type;
    ALTER TABLE sys_file_processedfile DROP zzz_deleted_sha1;
    ALTER TABLE sys_file_processedfile DROP zzz_deleted_size;
cache_imagesizes, Rows: 157, Description: Cached image sizes

I have deleted this also. And still no effect.

Then I have found out that at first this must be changed, otherwise the former steps have absolutely no result:

Image handling settings

The former TYPO3 version has used a different settings. The ImageMagick did not work correctly.

My proposal it to put all these steps into one automatic step inside of the Upgrade Wizard.

#3

Updated by Riccardo De Contardi almost 5 years ago

So, as far as I have understood, the problem was the wrong settings of imagemagick/graphicsmagick?

Question: Install tool > Configuration Presets: does it show an "alert badge" if no imagemagick/graphicsmagick executable can be found in the configured path?

Question #2: could be useful to show a warning in "Reports Module" (or In Install tool > System Environment)? (I don't remember, too if it already does)

#4

Updated by Franz Holzinger almost 5 years ago

The problem has been, that all the solutions did not work, because they did not tell anything about the ImageMagick settings.

Answer to question 1: Yes, if you open the closed 'Image handling settings' tab.

Answer to question 2: In previous versions of TYPO3 the Install Tool tab 'Important actions' did show the Image Magick alerts. Therefore it was not overseen so easily as with TYPO3 6.2. This is not there any more. Then there is the new 'Upgrade Wizard'. The Upgrade Wizard could set the necessary Image Magick configuration automatically. The System Environment of the Install Tool does not notify about the Image Magick settings.

#5

Updated by Alexander Opitz over 4 years ago

  • Status changed from Needs Feedback to New
#6

Updated by Riccardo De Contardi over 4 years ago

  • Status changed from New to Needs Feedback

If you agree I would
- change the bug tracker to "Feature"
- change the title to "install tool should warn about wrong/absent Imagemagick configuration on the tab 'Important actions' "
- add "install tool" as category

#7

Updated by Franz Holzinger over 4 years ago

@Riccardo: Thanks. Yes, I agree to your proposal to improve the Install Tool.

#8

Updated by Riccardo De Contardi over 4 years ago

  • Tracker changed from Bug to Feature
  • Subject changed from file maxW and maxH are ignored - part 2 to Install Tool should warn about wrong/absent Imagemagick configuration on the tab 'Important actions'
  • Category set to Install Tool
  • Status changed from Needs Feedback to New
#9

Updated by Riccardo De Contardi almost 4 years ago

  • Status changed from New to Closed

I close this issue as a duplicate of #62210 please continue the discussion there.

I've added a reference to this issue to keep track of it.

If you think that this is the wrong decision please reopen it or open a new issue with a reference to this one. Thank you.

Also available in: Atom PDF