Bug #72751

RTE: no TSconfig loaded on positioned insert

Added by Marco Huber almost 4 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
RTE (rtehtmlarea + ckeditor)
Target version:
-
Start date:
2016-01-15
Due date:
% Done:

100%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

If you insert a content element (or a page) with a RTE field at a concrete position f.e. after content element 15 the value in $row['pid'] is -15.

But with this "pid" the TSconfig can not be loaded.


Related issues

Related to TYPO3 Core - Bug #72092: RTE element tsconfig wrong if negative pid value (new element below other) Closed 2015-12-07
Related to TYPO3 Core - Bug #75254: Wrong page TSconfig in link wizard after positioned insert Closed 2016-03-24

Associated revisions

Revision 52b3f406 (diff)
Added by Marco Huber almost 4 years ago

[BUGFIX] Fix negativ pid when doing a positioned insert

If you insert a content element (or a page) at a concrete position f.e.
after content element 15 the value in $row['pid'] is -15.
But in $this->data we already have the real pid, so we can just use it.

Resolves: #72751
Releases: master,7.6
Change-Id: Ib441dacf68eebd377f48589b7aeff6af1159263d
Reviewed-on: https://review.typo3.org/45969
Reviewed-by: Georg Ringer <>
Tested-by: Georg Ringer <>
Reviewed-by: Morton Jonuschat <>
Tested-by: Morton Jonuschat <>

Revision ebdd1671 (diff)
Added by Marco Huber almost 4 years ago

[BUGFIX] Fix negativ pid when doing a positioned insert

If you insert a content element (or a page) at a concrete position f.e.
after content element 15 the value in $row['pid'] is -15.
But in $this->data we already have the real pid, so we can just use it.

Resolves: #72751
Releases: master,7.6
Change-Id: Ib441dacf68eebd377f48589b7aeff6af1159263d
Reviewed-on: https://review.typo3.org/45969
Reviewed-by: Georg Ringer <georg.ringer@gmail.com>
Tested-by: Georg Ringer <georg.ringer@gmail.com>
Reviewed-by: Morton Jonuschat <m.jonuschat@mojocode.de>
Tested-by: Morton Jonuschat <m.jonuschat@mojocode.de>
(cherry picked from commit 52b3f406c3ad16808c66cadd54d53657e4c2dce8)
Reviewed-on: https://review.typo3.org/46019

Revision 3e888e03 (diff)
Added by Marco Huber about 3 years ago

[BUGFIX] Fix negative pid when doing a positioned insert

If you insert a content element (or a page) at a concrete position f.e.
after content element 15 the value in $row['pid'] is -15.
This pseudo pid has to be converted to the real pid to get the right
page TsConfig.

Resolves: #75254
Related: #72751
Releases: master, 7.6
Change-Id: Ia2c7a34bf6c825709ca51aa32b84a5fc660817c3
Reviewed-on: https://review.typo3.org/47381
Reviewed-by: Markus Gehrig <>
Reviewed-by: Joerg Boesche <>
Reviewed-by: Anja Leichsenring <>
Tested-by: Anja Leichsenring <>
Reviewed-by: Jan Helke <>
Tested-by: Jan Helke <>

Revision 84eba275 (diff)
Added by Marco Huber about 3 years ago

[BUGFIX] Fix negative pid when doing a positioned insert

If you insert a content element (or a page) at a concrete position f.e.
after content element 15 the value in $row['pid'] is -15.
This pseudo pid has to be converted to the real pid to get the right
page TsConfig.

Resolves: #75254
Related: #72751
Releases: master, 7.6
Change-Id: Ia2c7a34bf6c825709ca51aa32b84a5fc660817c3
Reviewed-on: https://review.typo3.org/50400
Reviewed-by: Jan Helke <>
Tested-by: Jan Helke <>

History

#1 Updated by Gerrit Code Review almost 4 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/45969

#2 Updated by Marco Huber almost 4 years ago

Perhaps https://forge.typo3.org/issues/71609 is related.

I have read somewhere, that there is a great refactoring of the rtehtmlarea in progress. But this little patch already helps a lot :-)

#3 Updated by Gerrit Code Review almost 4 years ago

Patch set 1 for branch TYPO3_7-6 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/46019

#4 Updated by Marco Huber almost 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#5 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF