Project

General

Profile

Actions

Bug #71609

closed

RTE Options dont work

Added by Rainer Becker over 8 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
FormEngine aka TCEforms
Start date:
2015-11-16
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
5.5
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

It seems that the page TS options

RTE.default.buttons.link {
targetSelector.disabled = 1
popupSelector.disabled = 1
options.removeItems = folder
}

don’t have any effect anymore.


Related issues 2 (0 open2 closed)

Related to TYPO3 Core - Bug #71248: TSconfig: RTE.classesAnchor seems not to be working anymoreClosedAndreas Allacher2015-11-02

Actions
Related to TYPO3 Core - Bug #71978: $RTEProperties is never initializedClosed2015-11-30

Actions
Actions #1

Updated by Martin R. Krause over 8 years ago

  • Target version set to 7 LTS

In fact the whole TYPO3\CMS\Rtehtmlarea\Controller\BrowseLinksController class is not working properly. I debugged the issues and it is a miracle that the LinkBrowser for the RTE works at all.

In TYPO3 7.5 configuring classes for links was still possible, now the link property for classes does not show up at all.

The class BrowseLinksController that inherits from AbstractLinkBrowserController does not load the configuration. The order is wrong (e.g. $this->RTEProperties is not set at all, should be $RTEsetup['properties'] in method initVariables()). The $this->currentLinkHandlerId is never set, therefor button classes configuration could not be found etc.

Proposal for solution

The RTE should not have link configurations on its own anyway. It always was very tedious to configure both link handler (for RTE and TCA Link Wizard). Now that we have the TCEMAIN.linkhandler configuration in PageTS, this should also be the place to configure link options (classes, target, etc.). Getting rid of the cryptic RTE configuration for links would simplify integration and the development of the LinkHandler classes. In the RTE no <a /> should be added, just TYPO3 <link /> tags that have a syntax that is consistent with typolink.

Actions #2

Updated by Andreas Allacher over 8 years ago

Added #71248 as related.
I don't think it is a duplicate as it is related to different properties but maybe the same solution works (not tested - maybe someone wants to test, if so this ticket could be added in Resolves list)

Regarding currentLinkHandlerId there is another property for that (displayLinkHandlerId) which should be used instead, see also attached patch for related ticket.

Actions #3

Updated by Eric Chavaillaz over 8 years ago

Hi,

The problem is described here : https://forge.typo3.org/issues/71978

Thanks

Actions #4

Updated by Stephan Brun over 8 years ago

targetSelector.disabled works with 7.6.1

Could not test the other two options.

Actions #5

Updated by Riccardo De Contardi over 8 years ago

  • Target version changed from 7 LTS to Candidate for patchlevel
Actions #6

Updated by Riccardo De Contardi about 8 years ago

These are my findings:

6.2.22

RTE.default.buttons.link.targetSelector.disabled = 1 WORKS
RTE.default.buttons.link.popupSelector.disabled = 1 DOES NOT WORK (tested with RTE.default.buttons.link.targetSelector.disabled = 0)
RTE.default.buttons.link.options.removeItems = folder WORKS

7.6.6

RTE.default.buttons.link.targetSelector.disabled = 1 WORKS
RTE.default.buttons.link.popupSelector.disabled = 1 DOES NOT WORK (tested with RTE.default.buttons.link.targetSelector.disabled = 0)
RTE.default.buttons.link.options.removeItems = folder WORKS

8.2-dev

RTE.default.buttons.link.targetSelector.disabled = 1 WORKS
RTE.default.buttons.link.popupSelector.disabled = 1 DOES NOT WORK (tested with RTE.default.buttons.link.targetSelector.disabled = 0)
RTE.default.buttons.link.options.removeItems = folder WORKS

Actions #7

Updated by Christian Kuhn over 6 years ago

  • Assignee deleted (Christian Kuhn)
Actions #8

Updated by Benni Mack about 5 years ago

  • Related to Bug #71978: $RTEProperties is never initialized added
Actions #9

Updated by Benni Mack about 5 years ago

  • Status changed from New to Needs Feedback

Does this also occur with CKeditor?

Actions #10

Updated by Riccardo De Contardi almost 5 years ago

Hi Benni, I can answer you :)

Tried with latest 10.0.0-dev

RTE.default.buttons.link.targetSelector.disabled = 1 WORKS
RTE.default.buttons.link.popupSelector.disabled = 1 DOES NOT WORK (tested with RTE.default.buttons.link.targetSelector.disabled = 0)
RTE.default.buttons.link.options.removeItems = folder WORKS

I am not entirely sure that RTE.default.buttons.link.popupSelector.disabled = 1 is even present on TYPO3 versions 7.6.x or higher, maybe it has been removed?

Either I am looking at the wrong place, or the documentation here: https://docs.typo3.org/typo3cms/extensions/rtehtmlarea/7.6/Configuration/PageTsconfig/interfaceConfiguration/Index.html does not mention it (It does on the documentation of version 6.2)

Actions #11

Updated by Susanne Moog about 4 years ago

  • Status changed from Needs Feedback to Closed

The one Riccardo mentioned as not working has been removed - see https://docs.typo3.org/c/typo3/cms-core/master/en-us/Changelog/7.5/Important-69137-LinkWizardPopupWidthAndHeightFieldsRemoved.html - as the others now work, I'm closing this issue.

Actions

Also available in: Atom PDF