Project

General

Profile

Actions

Bug #72092

closed

Story #69617: FormEngine bugs

RTE element tsconfig wrong if negative pid value (new element below other)

Added by Andreas Allacher over 8 years ago. Updated almost 7 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
FormEngine aka TCEforms
Target version:
Start date:
2015-12-07
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

If an element is inserted below another element the pid value is negative which currently results in RTE Tsconfig not being extracted from current page.


Related issues 1 (0 open1 closed)

Related to TYPO3 Core - Bug #72751: RTE: no TSconfig loaded on positioned insertClosed2016-01-15

Actions
Actions #1

Updated by Andreas Allacher over 8 years ago

The issue is part of this code:

        $this->pidOfPageRecord = $table === 'pages' && MathUtility::canBeInterpretedAsInteger($row['uid']) ? (int)$row['uid'] : (int)$row['pid'];
        BackendUtility::fixVersioningPid($table, $row);
        $this->pidOfVersionedMotherRecord = (int)$row['pid'];

However, as a workspace can also have a negative value (-1) I guess it is necessary to check if new and if pidOfPageRecord is not different from pidOfVersionedMotherRecord before calling getPagesTSconfig

This is also an issue with RTE tsconfig for linkhandler as the same value (pidOfPageRecord) is passed on to the LinkHandler.

Actions #2

Updated by Frank Nägler over 8 years ago

  • Category changed from RTE (rtehtmlarea + ckeditor) to FormEngine aka TCEforms
  • Target version deleted (7.6.1)
Actions #3

Updated by Christian Kuhn over 8 years ago

  • Parent task set to #69617
Actions #4

Updated by Morton Jonuschat over 8 years ago

  • Status changed from New to Resolved
  • Target version set to 8.0

Fixed through issue #72751 / changeset 52b3f406c3ad16808c66cadd54d53657e4c2dce8.

Actions #5

Updated by Christian Kuhn about 8 years ago

  • % Done changed from 0 to 100
Actions #6

Updated by Riccardo De Contardi almost 7 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF