Bug #72812

rsaauth: IE caches xhr, problem with login after changing password

Added by Michal Cygankiewicz almost 5 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Authentication
Target version:
-
Start date:
2016-01-19
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Scenario:

1. I am logging as a frontend user.
2. Log out.
3. Forgot password, ask for new one.
4. I am not able to login again in IE (in other browser those scenario works fine) unless close and open browser again or clear all browser caches.

Seems like it is because of strange xhr caching strategy in IE. http://stackoverflow.com/questions/10950717/why-does-internet-explorer-cache-xhr-requests

Solution for that is to change

this.xhr.open('GET', url, true);

to POST in \typo3\sysext\rsaauth\resources\FrontendLoginFormRsaEncryption.js

Should we implement that change into core?


Related issues

Related to TYPO3 Core - Task #81852: Deprecate EXT:rsaauthClosedGeorg Ringer2017-07-13

Actions
#1

Updated by Mona Muzaffar about 3 years ago

  • Category set to Authentication
#2

Updated by Riccardo De Contardi about 3 years ago

#3

Updated by Riccardo De Contardi almost 2 years ago

  • Status changed from New to Closed

EXT:rsaauth has been decoupled from the TYPO3 Core (deprecated since 9.5 and removed on 10.0) , so its development has stopped and the code is now available on Github;

I'll close this issue for now, as EXT:rsaauth is now maintained as a separate extension by the FriendsOfTypo3 Team.

If you still need support on this issue, please open an issue at https://github.com/FriendsOfTYPO3/rsaauth

Also available in: Atom PDF