Bug #72835

Can't use search wizard before saving the content

Added by Loïc Stéphan almost 6 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
Could have
Assignee:
-
Category:
FormEngine aka TCEforms
Target version:
-
Start date:
2016-01-20
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
5.5
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

We use CE backend layout to build flexible content element.
The fields which use search wizard don't work if the content is not saved before : "No result" is displayed.

Once the content is saved, the search wizard works.


Files

search_wizard.JPG (13.3 KB) search_wizard.JPG Loïc Stéphan, 2016-01-20 14:40
flexform_teamcontent.txt (1.02 KB) flexform_teamcontent.txt Loïc Stéphan, 2016-01-20 16:08
suggest-wizard-new-record-tca.PNG (21.3 KB) suggest-wizard-new-record-tca.PNG Rachel Foucard, 2016-01-21 16:39
suggest-wizard-new-record-flexform.PNG (19.5 KB) suggest-wizard-new-record-flexform.PNG Rachel Foucard, 2016-01-21 16:39
suggest-wizard-new-record-tca.PNG (23.7 KB) suggest-wizard-new-record-tca.PNG Rachel Foucard, 2016-01-21 16:43
#1

Updated by Jo Hasenau almost 6 years ago

  • Status changed from New to Needs Feedback
  • Priority changed from Should have to Could have

Usually backend layouts do not provide additional fields. So what dou you mean by "search wizard" and what kind of fields are we talking about?

#2

Updated by Loïc Stéphan almost 6 years ago

We use tx_gridelements_backend_layout record, in field "pi_flexform_ds" we have one filed which is setup with this XML :

<TCEforms type="array">
    <label>Utilisateur</label>
    <config type="array">
        <type>select</type>
        <internal_type>db</internal_type>
        <allowed>fe_users</allowed>
        <size>1</size>
        <minitems>0</minitems>
        <maxitems>1</maxitems>
        <wizards type="array">
            <suggest type="array">
                <type>suggest</type>
                <default>
                    <searchWholePhrase>1</searchWholePhrase>
                </default>
            </suggest>
        </wizards>
    </config>
</TCEforms>

I attached a screen of the field with "search wizard".

#3

Updated by Jo Hasenau almost 6 years ago

So it's a flexform field with a suggest wizard.
Since there are several ways to create new elements, how did you do that and how do you get the populated flexform?

#4

Updated by Loïc Stéphan almost 6 years ago

The "grid element backend layout" was created manualy on a "Grid Element" folder.
This folder contains all flexible contents.

The flexform was taken from templavoila (we migrated from templavoila to gridelements) and cleaned.
The complete content of the flexform is added in attachment.

FYI : We use sf_tv2fluidge to migrate all templavoila contents to grid elements but the problem occurs with new content.

#5

Updated by Jo Hasenau almost 6 years ago

Actually the question was about how you create the content elements when you already provided the layout.
So do you use the drag in wizard, are you clicking on "+ Content" or how else did you create that particular content element when the actual error happens?

BTW: Actually the purpose of Gridelements was to get rid of the flexforms introduced by TemplaVoila, so maybe this can be solved without using a flexform at all.

#6

Updated by Loïc Stéphan almost 6 years ago

We are clicking on "+ Content" then we choose "Grid Elements" tab, finaly we pick the name of our flexible content.
Once the content is loaded, we seek a user and we have "no result" message.

#7

Updated by Jo Hasenau almost 6 years ago

Currently I'm not sure, if this is a bug, since there is no ID when you create a new content element, which of course changes when you save and reload the element.
Could you please check, if there is any JavaScript error involved, when you click on the suggest wizard?

As a workaround you could go for the drag in wizard for the moment, so you can drag in a new element, which will create that ID as well, and then open it for editing.

#8

Updated by Jo Hasenau almost 6 years ago

  • Project changed from 2513 to TYPO3 Core
  • Category set to FormEngine aka TCEforms
  • Status changed from Needs Feedback to New
  • PHP Version set to 5.5
  • Is Regression set to No

I checked the behaviour with the plugin section of the Login Form content element type and the behaviour is exactly the same, so this is not a Gridelement but a common flexform issue.

You have to save the editing form of a newly created element once, before any suggest wizard of that flexform field will give back correct results.

#9

Updated by Wouter Wolters almost 6 years ago

  • Status changed from New to Closed

I'm closing this one down.
Not because it's not valid, but because this is something inherited so deep in FormEngine.
Here are some other variations of that report:

Changing a CType causes forms to be reloaded
Changing typeFields require a reload

In order to make this work we need to rebuild FormEngine so it can reloadForms via AJAX.

We have this on our agenda.

#10

Updated by Loïc Stéphan almost 6 years ago

OK, thank you for having spent time for this problem.

#11

Updated by Rachel Foucard almost 6 years ago

Hello,

I'm sorry to go on, but I'm not sure that the problem has been found.

Here are two screenshots that explain the situation:

if you create a new page without saving, the "suggest wizard" based on the TCA works well.
if you create a new plugin content "news" without saving, the "suggest wizard" based on a flexform doesn't work.

Do we really need to save a record so that the "suggest wizard" based on flexform works as well as the other?
is there no other solution?

thank you again,

Rachel Foucard.

#12

Updated by Rachel Foucard almost 6 years ago

sorry, the first file was not good.
Cheers,
Rachel Foucard.

Also available in: Atom PDF