Bug #73472

cut button / menu entry not removed on pages without write permissions

Added by Peter Kraume over 4 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2016-02-16
Due date:
% Done:

100%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

On pages where the editor does not have write permissions, the cut button isn't removed.
If you try to cut a page or content element and paste it somewhere else where you have write access, the action fails without any error message.
This bug effects page and list module.

How to reproduce:
- give editor only read access to a page
- cut a page or content element
- paste it somewhere else

occurrence of the cut button / menu entry:

Page Module:
- pagetree context menu
- context menu of content elements

List Module:
- every record


Related issues

Related to TYPO3 Core - Bug #73470: Pagetree context menu entry missing to copy pages without write permissions Closed 2016-02-16
Related to TYPO3 Core - Bug #73591: Page Module: Click menu in content elements missing if editor has only read access Closed 2016-02-22
Duplicated by TYPO3 Core - Feature #73564: Check "cut" permission for pages or content in recordlist Closed 2016-02-19

Associated revisions

Revision b5967aa2 (diff)
Added by Gianluigi Martino over 4 years ago

[TASK] Check if user have permission to cut records

Only show cut icons when the user has write-permissions on the
specific record.

Change-Id: I0d5a1153faf448f9c1c6c0948f2cdf8f78cab8f6
Resolves: #73564, #73472
Releases: master, 7.6
Reviewed-on: https://review.typo3.org/46774
Reviewed-by: Peter Kraume <>
Tested-by: Peter Kraume <>
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>

Revision 07faca22 (diff)
Added by Gianluigi Martino over 4 years ago

[TASK] Check if user have permission to cut records

Only show cut icons when the user has write-permissions on the
specific record.

Change-Id: I0d5a1153faf448f9c1c6c0948f2cdf8f78cab8f6
Resolves: #73564, #73472
Releases: master, 7.6
Reviewed-on: https://review.typo3.org/46876
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>

History

#1 Updated by Richard Haeser over 4 years ago

  • Assignee set to Richard Haeser

#2 Updated by Gianluigi Martino over 4 years ago

I have already created a patch for recordlist.

https://review.typo3.org/#/c/46774/

Cannot reproduce the problem with the pagetree

#3 Updated by Gianluigi Martino over 4 years ago

I have already created a patch for recordlist.

https://review.typo3.org/#/c/46774/

Cannot reproduce the problem with the pagetree

#4 Updated by Richard Haeser over 4 years ago

Gianluigi Martino wrote:

I have already created a patch for recordlist.

https://review.typo3.org/#/c/46774/

Cannot reproduce the problem with the pagetree

Maybe mention this issue in your commit-message as well?

#5 Updated by Richard Haeser over 4 years ago

  • Status changed from New to Under Review

#6 Updated by Peter Kraume over 4 years ago

I've tested the patch. Looks fine so far. Thank you very much for your effort so far!
The info regarding the page tree is wrong, you can ignore that.

Maybe you can have a look at #73591 and #73470 as well, since these problems relate to the current problem.

#7 Updated by Gianluigi Martino over 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#8 Updated by Benni Mack over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF