Bug #73604

Story #69617: FormEngine bugs

Nested localizations in page module get wrong language pointers

Added by Oliver Hader over 3 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Localization
Target version:
Start date:
2016-02-22
Due date:
% Done:

0%

TYPO3 Version:
7
PHP Version:
5.5
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Scenario:
  • two additional languages
    • 0/default (english)
    • 1 (german)
    • 2 (french)
  • content element
    • image reference as nested element
  • alternative page localizations (pages_language_overlay) are available already
Test A:
  • for language "german" (uid 1)
  • "translate" button in the page-module
  • use "localization" mode
  • chose "default" as base
  • all fine in sys_file_reference of new localization
    • sys_language_uid points to german (uid 1)
    • l10n_parent points to sys_file_reference of default language
Test B:
  • for language "french" (uid 2)
  • "translate" button in the page-module
  • use "localization" mode
  • chose "german" as base
  • wrong pointers in sys_file_reference of new localization
    • sys_language_uid points to german (uid 1) instead of french (uid 1)
    • l10n_parent points to sys_file_reference of default language instead of german

sys_file_reference.png View (25.3 KB) Tymoteusz Motylewski, 2016-11-25 15:14


Related issues

Related to TYPO3 Core - Bug #78059: Checks in DataHandler localize mismatch with new Localization Wizard Closed 2016-09-25

History

#1 Updated by Ralf Merz over 3 years ago

Hello,

I can confirm Test A and B and even the other way around:
- first translate to French, everything┬┤s fine (check sys_language_uid in sys_file_reference).
- Then translate to German, with French as source, and you will see that the sys_file_references will have the value 2 instead of 1 for sys_language_uid. And the l10n_parent is set from the default language (which may be right, I don┬┤t know that).

Yours
merzilla

#2 Updated by Oliver Hader over 3 years ago

  • Status changed from New to Accepted

#3 Updated by Benjamin no-lastname-given over 3 years ago

This issue might be related to something i am investigating ( https://github.com/FluidTYPO3/flux/issues/1099 ).
I think the problem is that the copyRecord function call in DataHandler:L3320 does not know about the Language in the $pasteUpdate variable.

#5 Updated by Tymoteusz Motylewski almost 3 years ago

seems like it's duplicated by the https://forge.typo3.org/issues/78059

#6 Updated by Tymoteusz Motylewski over 2 years ago

  • Target version set to 8 LTS

#7 Updated by Tymoteusz Motylewski over 2 years ago

"l10n_parent points to sys_file_reference of default language" - is that's right?
shouldn't l10n_parent always be in the default language?

#8 Updated by Tymoteusz Motylewski over 2 years ago

Can not confirm the issue with current master (v8) and tt_content.

attached screenshot (sys_file_reference.png) of the db after following scenario:
1. tt_content:55 has 2 images, sys_file_reference:193 and sys_file_reference:194
2. tt_content:55 is translated using "translation" mode in translation wizard to language
3. New tt_content:263 is created with sys_file_reference:201 and 202
4. tt_content:263 is translated using "translation" mode in translation wizard to language
5. New tt_content:269 is created with sys_file_reference:207 and 208

All sys_file_references have l10n_parent set to correct value (record uid in the default language).

#9 Updated by Oliver Hader over 2 years ago

  • Status changed from Needs Feedback to Closed

Correct. This issue has been a duplicate of issue #78059 and has been fixed already in master an 7.6.

Also available in: Atom PDF