Bug #73616

Different standards used in GeneralUtility::validEmail (RFC 3696) and swiftmailers Swift_Mime_Grammar-class (RFC 2822)

Added by Christian Eßl over 5 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2016-02-23
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Tested in 6.2.18, but may also occur in current versions.

At the moment GeneralUtility::validEmail() is following RFC3696, where as the internally used swiftmailer is follwing RFC 2822.
We had a case where an email with the format "user@¹gmx.at" was checked as valid by TYPO3s internal function but lead to an Swift_RfcComplianceException when sending an email.

The problem may or may not occur because of the different standards that were used. Currently this would mean, that as a TYPO3 developer you would always have to check against the \Swift_Mime_Grammar instead of GeneralUtility::validEmail() to be on the safe side, if the email at some time should be sent by TYPO3s internal methods.


Related issues

Related to TYPO3 Core - Bug #81524: Cannot send mails with special characters in local partClosed2017-06-09

Actions
Related to TYPO3 Core - Bug #87077: Scheduler: Notification email address (e.g. system report) does not allow a local mail addressClosed2018-12-04

Actions
Related to TYPO3 Core - Feature #87691: Allow email adresses with "+" in GeneralUtility::validEmail()Closed2019-02-11

Actions
Related to TYPO3 Core - Feature #90370: Use Egulias\EmailValidator for email validationClosed2020-02-13

Actions
#1

Updated by Mathias Brodala about 4 years ago

  • Related to Bug #81524: Cannot send mails with special characters in local part added
#2

Updated by Georg Ringer over 2 years ago

  • Related to Bug #87077: Scheduler: Notification email address (e.g. system report) does not allow a local mail address added
#3

Updated by Georg Ringer over 2 years ago

  • Related to Feature #87691: Allow email adresses with "+" in GeneralUtility::validEmail() added
#5

Updated by Georg Ringer over 1 year ago

  • Status changed from New to Closed

solved with #90370

#6

Updated by Georg Ringer over 1 year ago

  • Related to Feature #90370: Use Egulias\EmailValidator for email validation added

Also available in: Atom PDF