Bug #81524

Cannot send mails with special characters in local part

Added by Mathias Brodala almost 4 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Start date:
2017-06-09
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Currently it is impossible to send mails with special characters in their local part, e.g. john.lötzsch@example.org. Swiftmailer fails with the following error:

 [ Swift_RfcComplianceException ]
 Address in mailbox given [john.lötzsch@example.org] does not comply with RFC 2822, 3.6.2.
 thrown in file er/lib/classes/Swift/Mime/Headers/MailboxHeader.php
 in line 345

The mentioned RFC 2822 has been extended by RFC 5335 which is supported by Swiftmailer 6.x and newer, thus an upgrade is necessary. This implies a few breaking changes however.


Related issues

Related to TYPO3 Core - Bug #73616: Different standards used in GeneralUtility::validEmail (RFC 3696) and swiftmailers Swift_Mime_Grammar-class (RFC 2822)Closed2016-02-23

Actions
Related to TYPO3 Core - Bug #87077: Scheduler: Notification email address (e.g. system report) does not allow a local mail addressClosed2018-12-04

Actions
Related to TYPO3 Core - Feature #90370: Use Egulias\EmailValidator for email validationClosed2020-02-13

Actions
#1

Updated by Mathias Brodala almost 4 years ago

  • Related to Bug #73616: Different standards used in GeneralUtility::validEmail (RFC 3696) and swiftmailers Swift_Mime_Grammar-class (RFC 2822) added
#2

Updated by Susanne Moog over 2 years ago

  • Target version changed from 9 LTS to Candidate for patchlevel
#3

Updated by Georg Ringer over 2 years ago

  • Related to Bug #87077: Scheduler: Notification email address (e.g. system report) does not allow a local mail address added
#5

Updated by Mathias Brodala over 1 year ago

The issue is still present in TYPO3v10. When I use the "Test Mail Setup" I get this:

Mail not sent
Given address is not a valid email address.

#6

Updated by Georg Ringer over 1 year ago

There are 2 issues currently:

- \TYPO3\CMS\Core\Utility\GeneralUtility::validEmail fails with that
- \Symfony\Component\Mime\Encoder\IdnAddressEncoder::encodeString throws an exception

the latter has following comment

 * This encoder does not support email addresses with non-ASCII characters in
 * local-part (the substring before @). To send to such addresses, use
 * Utf8AddressEncoder together with SmtpUtf8Handler. Your outbound SMTP server must support
 * the SMTPUTF8 extension.

#7

Updated by Georg Ringer about 1 year ago

  • Related to Feature #90370: Use Egulias\EmailValidator for email validation added
#8

Updated by Georg Ringer about 1 year ago

resolved with #90370

#9

Updated by Georg Ringer about 1 year ago

  • Status changed from New to Closed

Also available in: Atom PDF