Bug #73751

columnsOverrides don't work with IRRE Elements

Added by Witali Rott over 3 years ago. Updated about 2 years ago.

Status:
Rejected
Priority:
Must have
Assignee:
-
Category:
-
Target version:
-
Start date:
2016-02-29
Due date:
% Done:

0%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

I tried to override the assets in tt_content with:

'columnsOverrides' => array(
    'assets' => array(
        'config' => array(
            'foreign_types' => array(
                0 => array(
                    'showitem' => '--palette--;LLL:EXT:lang/locallang_tca.xlf:sys_file_reference.imageoverlayPalette;imageoverlayPalette, --palette--;;filePalette,my_field'
                ),
                1 => array(
                    'showitem' => '--palette--;LLL:EXT:lang/locallang_tca.xlf:sys_file_reference.imageoverlayPalette;imageoverlayPalette, --palette--;;filePalette,my_field'
                ),
                2 => array(
                    'showitem' => '--palette--;LLL:EXT:lang/locallang_tca.xlf:sys_file_reference.imageoverlayPalette;imageoverlayPalette, --palette--;;filePalette,my_field'
                ),
                3 => array(
                    'showitem' => '--palette--;LLL:EXT:lang/locallang_tca.xlf:sys_file_reference.imageoverlayPalette;imageoverlayPalette, --palette--;;filePalette,my_field'
                ),
                4 => array(
                    'showitem' => '--palette--;LLL:EXT:lang/locallang_tca.xlf:sys_file_reference.imageoverlayPalette;imageoverlayPalette, --palette--;;filePalette,my_field'
                ),
                5 => array(
                    'showitem' => '--palette--;LLL:EXT:lang/locallang_tca.xlf:sys_file_reference.imageoverlayPalette;imageoverlayPalette, --palette--;;filePalette,my_field'
                ),
            )
        )
    ),
),

On create it works fine, but on reopen it (details) it doesn't show my_field.

FormInlineAjaxController.php.patch View (2.78 KB) Witali Rott, 2016-02-29 15:25

FormInlineAjaxController.php.patch View (2.58 KB) Philipp Kitzberger, 2016-05-30 18:20


Related issues

Related to TYPO3 Core - Bug #71436: Inline in flex with multiple DS fails Closed 2015-11-09
Related to TYPO3 Core - Feature #76671: columnsOverrides does not affect newly added inline elements Closed 2016-06-17

History

#1 Updated by Christian Kuhn over 3 years ago

  • Status changed from New to Rejected

yes. columnsOverrides on parent to change tca of irre children does not work. this limitation is hard to solve and will not be changed soon. i'll close this issue as rejected for now.

#3 Updated by XIMA MEDIA GmbH over 3 years ago

The patch #2 does not work. The 500 error still exists with TYPO3 7.6.4.

#4 Updated by ondro no-lastname-given over 3 years ago

With the combination of patch from here [[https://forge.typo3.org/issues/71436]]

FormInlineAjaxController.php.patch  Magnifier - Patch for TYPO3 7.6.3-7.6.4 (1.6 kB) Witali Rott, 2016-02-23 12:52

It works for me in typo3 v 7.6.5

#5 Updated by Philipp Kitzberger about 3 years ago

I just attached a patch that combines the two patches from #71436 and here. Works for me in TYPO3 7.6.9.

#6 Updated by Philipp Kitzberger about 3 years ago

I'd like to see this issue reopened and the patches taken into consideration for the current LTS since it's obviously a bug. I can confirm the patches to be working for at least two of our projects.

#7 Updated by Ingo Dirscherl about 3 years ago

Hey Christian, please can you have a look on the patches from Philipp Kitzberger. Maybe this is the Solution for this bug. It would be fine to patch it in the core. Thanks so much

#8 Updated by Nicole Cordes about 3 years ago

AFAIK you can push the patch to Gerrit (our review system) which would re-open this ticket automatically.

#9 Updated by Markus Kobligk almost 3 years ago

Can anyone please push the patch to Gerrit?
I can confirm this patch works, we use it in production systems and for every new project.

#10 Updated by Leonie Philine Bitto about 2 years ago

bump Please merge into the core!

This patch also fixes https://forge.typo3.org/issues/71436 (confimed on TYPO3 7.6.18)

Also available in: Atom PDF