Feature #76671

Story #69712: Further FormEngine development

columnsOverrides does not affect newly added inline elements

Added by Morten Haggren over 3 years ago. Updated 12 months ago.

Status:
Closed
Priority:
Won't have this time
Assignee:
-
Category:
FormEngine aka TCEforms
Target version:
-
Start date:
2016-06-17
Due date:
% Done:

100%

PHP Version:
5.5
Tags:
Complexity:
hard
Sprint Focus:

Description

In 7.6 I'm using the "columnsOverrides" feature to remove the link and description fields from tt_content's image field for certain ctypes, like so;

$GLOBALS['TCA']['tt_content']['ctrl']['types']['bootstrap_package_post']['columnsOverrides']['image']['config']['foreign_types'][\TYPO3\CMS\Core\Resource\File::FILETYPE_IMAGE]['showitem']='title,alternative,crop,--palette--;;filePalette';

This works perfectly when I go to edit an element with an image already attached.

But when I add a new image (before saving) the link and description fields are shown until I save.


Related issues

Related to TYPO3 Core - Bug #73751: columnsOverrides don't work with IRRE Elements Rejected 2016-02-29
Related to TYPO3 Core - Bug #71729: foreign_record_defaults stopped working inside columnsOverrides Rejected 2015-11-20
Related to TYPO3 Core - Bug #69183: Respect TCA option 'columnsOverrides' for server side field evaluations On Hold 2015-08-19
Duplicated by TYPO3 Core - Bug #79057: TCA IRRE columnsOverrides "foreign_record_defaults" not applied on new element Closed 2016-12-21
Duplicated by TYPO3 Core - Bug #79619: columnsOverride collapsed in sys_file_reference not working Closed 2017-02-03

Associated revisions

Revision 72f6ad28 (diff)
Added by Christian Kuhn over 2 years ago

[BUGFIX] Do not compile parent config in inline ajax controller

Using the signed parent tca config incoming via ajax request in the
inline ajax controller solves a series of issues in 'new' and other
scopes.
The expensive calculation of inline parent TCA config within the
controller can be dropped.

Change-Id: I4ff31d0398ebfa1bb311bbe6ea97c839aa2df1ac
Resolves: #80325
Resolves: #76671
Releases: master
Reviewed-on: https://review.typo3.org/52077
Reviewed-by: Anja Leichsenring <>
Tested-by: Anja Leichsenring <>
Tested-by: TYPO3com <>
Reviewed-by: Tobi Kretschmann <>
Tested-by: Tobi Kretschmann <>
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>

History

#1 Updated by Christian Kuhn about 3 years ago

  • Tracker changed from Bug to Feature
  • Priority changed from Should have to Won't have this time
  • Parent task set to #69712
  • Complexity set to hard

Yes, that's correct.

It is currently impossible to overwrite the TCA of inline children via "foreign_types" (and some other TCA settings that affect the TCA of inline children) depending on the type of the parent: Using those settings within columnsOverrides will have no effect. Background is that the parent type is not always known when i child is created, for instance if the parent is "new" and not yet persisted. This restriction can not be solved easily.

Since the columnsOverrides construct is new in 7.6 and provides more than it has been possible with 6.2, this report is rather a feature request that a bug or regression.

I'll keep it open but assign it to the parent issue "further formengine development".

#2 Updated by Gerrit Code Review over 2 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52077

#3 Updated by Gerrit Code Review over 2 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52077

#4 Updated by Gerrit Code Review over 2 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52077

#5 Updated by Christian Kuhn over 2 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#6 Updated by Benni Mack 12 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF