Bug #75520

Constant editor cut off "m" on image width and height

Added by Falk no-lastname-given about 4 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
TypoScript
Target version:
-
Start date:
2016-04-11
Due date:
% Done:

100%

TYPO3 Version:
7
PHP Version:
5.6
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

If I change and save constants with the constant editor (e.g. styles.content.textmedia.linkWrap.lightboxRelAttribute or any other) by the following constants the "m" is cutting off.

styles.content.textmedia.linkWrap.width = 1140m
styles.content.textmedia.linkWrap.height = 600m

Best
Falk

Associated revisions

Revision 60182c41 (diff)
Added by Wouter Wolters almost 4 years ago

[BUGFIX] Correct type for constants linkWrap height and width

The height and width have a default value with a "m" in it.
This is stripped of because the wrong data type is used. Use string
instead to circumvent the automatic stripping of the letter "m".

Resolves: #75520
Releases: master,7.6
Change-Id: I36c18e955db50ecd981efd24a0f842706d8d0fdc
Reviewed-on: https://review.typo3.org/48375
Reviewed-by: Oliver Hader <>
Tested-by: Oliver Hader <>
Reviewed-by: Michael Oehlhof <>
Reviewed-by: Markus Klein <>
Tested-by: Markus Klein <>

Revision 6ac9b755 (diff)
Added by Wouter Wolters almost 4 years ago

[BUGFIX] Correct type for constants linkWrap height and width

The height and width have a default value with a "m" in it.
This is stripped of because the wrong data type is used. Use string
instead to circumvent the automatic stripping of the letter "m".

Resolves: #75520
Releases: master,7.6
Change-Id: I36c18e955db50ecd981efd24a0f842706d8d0fdc
Reviewed-on: https://review.typo3.org/48382
Reviewed-by: Markus Klein <>
Tested-by: Markus Klein <>

History

#1 Updated by Riccardo De Contardi about 4 years ago

I guess it is because of the comments inside Constants.txt:

# cat=content/cTextmedia/c1; type=int+; label= Click-enlarge Media Width: This specifies the width of the enlarged media element when click-enlarge is enabled
# cat=content/cTextmedia/c2; type=int+; label= Click-enlarge Media Height: This specifies the height of the enlarged media element when click-enlarge is enabled

#2 Updated by Riccardo De Contardi about 4 years ago

  • Category set to TypoScript

#3 Updated by Gerrit Code Review almost 4 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/48375

#4 Updated by Gerrit Code Review almost 4 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/48375

#5 Updated by Gerrit Code Review almost 4 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/48375

#6 Updated by Gerrit Code Review almost 4 years ago

Patch set 1 for branch TYPO3_7-6 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/48382

#7 Updated by Wouter Wolters almost 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#8 Updated by Benni Mack over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF