Bug #75606

Story #69617: FormEngine bugs

Override label of a flexform field with pageTSconfig not possible anymore

Added by Stefan Froemken about 5 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
FormEngine aka TCEforms
Target version:
Start date:
2016-04-14
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
7
PHP Version:
5.6
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Hello Core-Team,

following pageTSconfig does not work anymore:

TCEFORM.tt_content.pi_flexform.events2_events.list.settings\.preFilterByOrganizer.label = Organizer
TCEFORM.tt_content.pi_flexform.events2_events.sDEFAULT.settings\.categories.label = Categories

Stefan Frömken


Related issues

Related to TYPO3 Core - Bug #72961: TCA: using renderMode = tree, the treeConfig => rootUid can't get substituted with Page TSconfigClosed2016-01-27

Actions
#1

Updated by Christian Kuhn about 5 years ago

  • Category changed from DataHandler aka TCEmain to FormEngine aka TCEforms
#2

Updated by Christian Kuhn about 5 years ago

  • Parent task set to #69617
#3

Updated by Christian Kuhn about 5 years ago

yes. pageTS to flex form still has issues. i hope to find time for a bugfix session in this area soon ofter t3uxw16

#4

Updated by Christian Kuhn almost 5 years ago

nasty.

docu link: https://docs.typo3.org/typo3cms/TSconfigReference/PageTsconfig/TCEform/Index.html

docu example:
TCEFORM.tt_content.pi_flexform.my_ext_pi1.sDEF.myField.label = ...

All the other settings like addItems and friends are handled properly.

The issue is here that the label value is determined very late in the container structure, according code can be found in PaletteAndSingleContainer getSingleFieldLabel() and similar stuff is not done in FlexFormElementContainer. The problem is that the pageTsConfig / fieldTSconfig / fieldTSConfig (sic!) is not properly available for flex form fields in this area anymore, it is rather hidden in the "global" pageTsConfig and can not be accessed that easily anymore. I guess this could be the root cause for further different page ts config related issues with flex forms, too.

In this case it seems to be best to handle the full pageTsConfig mapping onto the tca / fake-tca-of-flex for the label stuff in one or multiple data providers instead of doing that within the containers. basically, getSingleFieldLabel() should be merged into or created as new provider and the result can probably just be set into the according tca stuff.

This would reduce the overall dependency of the container / element render-structure to page ts config, and that would be a good idea anyway.

#5

Updated by Christian Kuhn almost 5 years ago

btw: this issue can be tested pretty easily with ext:news

TCEFORM.tt_content.pi_flexform.news_pi1.sDEF.settings\.orderBy.label = KLAUS

#6

Updated by Gerrit Code Review almost 5 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47919

#7

Updated by Gerrit Code Review almost 5 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47919

#8

Updated by Gerrit Code Review almost 5 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47919

#9

Updated by Gerrit Code Review almost 5 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47919

#10

Updated by Gerrit Code Review almost 5 years ago

Patch set 1 for branch TYPO3_7-6 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47939

#11

Updated by Christian Kuhn almost 5 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#12

Updated by Riccardo De Contardi over 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF